aboutsummaryrefslogtreecommitdiffstats
path: root/math/cln
diff options
context:
space:
mode:
Diffstat (limited to 'math/cln')
-rw-r--r--math/cln/Makefile13
-rw-r--r--math/cln/distinfo4
-rw-r--r--math/cln/pkg-plist105
3 files changed, 109 insertions, 13 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 4d2cfc22d30..81480173e98 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= cln
-PORTVERSION= 1.1.9
+PORTVERSION= 1.1.10
CATEGORIES= math devel
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/gnu/
@@ -17,7 +17,7 @@ COMMENT= Class Library for Numbers
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_BZIP2= yes
-USE_GCC= 3.4
+USE_GCC= 3.4+
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -32,13 +32,10 @@ INFO= cln
STRIP= # none
+CFLAGS+= -fPIC
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
@@ -52,9 +49,5 @@ post-install:
@${MKDIR} ${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
.endif
- @${FIND} ${PREFIX}/include/cln -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/include/cln ! -type f | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/math/cln/distinfo b/math/cln/distinfo
index 0c8e749b38d..04f77397f10 100644
--- a/math/cln/distinfo
+++ b/math/cln/distinfo
@@ -1,2 +1,2 @@
-MD5 (cln-1.1.9.tar.bz2) = 76fbeeeeac1559e482b404b4674915e2
-SIZE (cln-1.1.9.tar.bz2) = 1661135
+MD5 (cln-1.1.10.tar.bz2) = f194811dadcd2b1dca5f78a62370eb56
+SIZE (cln-1.1.10.tar.bz2) = 1702241
diff --git a/math/cln/pkg-plist b/math/cln/pkg-plist
index 635bceba28f..d3dae7fbf36 100644
--- a/math/cln/pkg-plist
+++ b/math/cln/pkg-plist
@@ -1,6 +1,109 @@
bin/cln-config
+include/cln/GV.h
+include/cln/GV_complex.h
+include/cln/GV_integer.h
+include/cln/GV_modinteger.h
+include/cln/GV_number.h
+include/cln/GV_rational.h
+include/cln/GV_real.h
+include/cln/SV.h
+include/cln/SV_complex.h
+include/cln/SV_integer.h
+include/cln/SV_number.h
+include/cln/SV_rational.h
+include/cln/SV_real.h
+include/cln/SV_ringelt.h
+include/cln/V.h
+include/cln/abort.h
+include/cln/cln.h
+include/cln/complex.h
+include/cln/complex_class.h
+include/cln/complex_io.h
+include/cln/complex_ring.h
+include/cln/condition.h
+include/cln/config.h
+include/cln/dfloat.h
+include/cln/dfloat_class.h
+include/cln/dfloat_io.h
+include/cln/ffloat.h
+include/cln/ffloat_class.h
+include/cln/ffloat_io.h
+include/cln/float.h
+include/cln/float_class.h
+include/cln/float_io.h
+include/cln/floatformat.h
+include/cln/floatparam.h
+include/cln/input.h
+include/cln/integer.h
+include/cln/integer_class.h
+include/cln/integer_io.h
+include/cln/integer_ring.h
+include/cln/intparam.h
+include/cln/io.h
+include/cln/lfloat.h
+include/cln/lfloat_class.h
+include/cln/lfloat_io.h
+include/cln/malloc.h
+include/cln/modinteger.h
+include/cln/modules.h
+include/cln/null_ring.h
+include/cln/number.h
+include/cln/number_io.h
+include/cln/numtheory.h
+include/cln/object.h
+include/cln/output.h
+include/cln/proplist.h
+include/cln/random.h
+include/cln/rational.h
+include/cln/rational_class.h
+include/cln/rational_io.h
+include/cln/rational_ring.h
+include/cln/real.h
+include/cln/real_class.h
+include/cln/real_io.h
+include/cln/real_ring.h
+include/cln/ring.h
+include/cln/sfloat.h
+include/cln/sfloat_class.h
+include/cln/sfloat_io.h
+include/cln/string.h
+include/cln/symbol.h
+include/cln/timing.h
+include/cln/types.h
+include/cln/univpoly.h
+include/cln/univpoly_complex.h
+include/cln/univpoly_integer.h
+include/cln/univpoly_modint.h
+include/cln/univpoly_rational.h
+include/cln/univpoly_real.h
+include/cln/version.h
lib/libcln.a
lib/libcln.so
-lib/libcln.so.3
+lib/libcln.so.4
libdata/pkgconfig/cln.pc
share/aclocal/cln.m4
+%%PORTDOCS%%%%DOCSDIR%%/dvi/cln.dvi
+%%PORTDOCS%%%%DOCSDIR%%/html/cln.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_10.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_12.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_13.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_14.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_15.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_16.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_9.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_abt.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_ovr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/cln_toc.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/dvi
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/cln