aboutsummaryrefslogtreecommitdiffstats
path: root/math/fxt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/fxt/Makefile')
-rw-r--r--math/fxt/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 05fd6198cf8..2fce4bf3644 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -2,33 +2,33 @@
# $FreeBSD$
PORTNAME= fxt
-PORTVERSION= 2015.07.17
-PORTREVISION= 1
+PORTVERSION= 2016.02.27
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
MAINTAINER= ports@FreeBSD.org
COMMENT= FFT code and related stuff
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake tar:tgz
+MAKE_ENV= FXT_INSTALL="${INSTALL_DATA}"
MAKEFILE= makefile
OPTIONS_DEFINE= EXAMPLES
post-patch:
- @${REINPLACE_CMD} -E \
- -e 's,^(FXT_CXXFLAGS),#\1,' \
- -e 's,^(CXXFLAGS),#\1,' \
- ${WRKSRC}/makefile
- @${REINPLACE_CMD} -e 's|sinl|Sin|g' ${WRKSRC}/src/aux0/trigrec.h
- @${REINPLACE_CMD} -e 's|sinl|sin|g' ${WRKSRC}/src/fht/hartleyshift.h
+ @${REINPLACE_CMD} -e \
+ 's|^\(FXT_CXXFLAGS\)|#\1| ; \
+ s|\([[:space:]]\)\($$(INCDIR)\)|\1$$(DESTDIR)\2|g ; \
+ s|\([[:space:]]\)\($$(LIBDIR)\)|\1$$(DESTDIR)\2|g' \
+ ${WRKSRC}/makefile
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}/)
+ (cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>