aboutsummaryrefslogtreecommitdiffstats
path: root/math/jakarta-commons-math/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/jakarta-commons-math/Makefile')
-rw-r--r--math/jakarta-commons-math/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index 0b4d75496d6..c867b8b730e 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -5,21 +5,19 @@ PORTNAME= commons-math
PORTVERSION= 2.2
PORTREVISION= 1
CATEGORIES= math java
-MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}/:source1 \
+MASTER_SITES= APACHE_COMMONS_SOURCE \
http://repo1.maven.org/maven2/junit/junit/4.8.2/:source2
-MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-math,math,}/:source1
PKGNAMEPREFIX= jakarta-
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tar.gz:source1 \
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
junit-4.8.2.jar:source2
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-src.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bofh@FreeBSD.org
COMMENT= Java library of self-contained mathematics and statistics components
LICENSE= APACHE20
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes