aboutsummaryrefslogtreecommitdiffstats
path: root/math/lp_solve/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/lp_solve/Makefile')
-rw-r--r--math/lp_solve/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/lp_solve/Makefile b/math/lp_solve/Makefile
index 3666e858abf..1f6db86c169 100644
--- a/math/lp_solve/Makefile
+++ b/math/lp_solve/Makefile
@@ -19,6 +19,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:R:R}
USE_LDCONFIG= yes
+.if defined(TMPDIR)
+BUILDENV= ${ENV} TMPDIR="${TMPDIR}"
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -39,9 +43,9 @@ post-patch:
s|-ldl||g"
do-build:
- cd ${WRKSRC}/lp_solve ; ${SH} -x ccc
- cd ${WRKSRC}/demo ; ${SH} -x ccc
- cd ${WRKSRC}/lpsolve55 ; ${SH} -x ccc
+ cd ${WRKSRC}/lp_solve ; ${BUILDENV} ${SH} -x ccc
+ cd ${WRKSRC}/demo ; ${BUILDENV} ${SH} -x ccc
+ cd ${WRKSRC}/lpsolve55 ; ${BUILDENV} ${SH} -x ccc
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lp_solve/bin/${LPSOLVE_ARCH}/lp_solve ${PREFIX}/bin