aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-SimpleVariable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Math-SimpleVariable/Makefile')
-rw-r--r--math/p5-Math-SimpleVariable/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/p5-Math-SimpleVariable/Makefile b/math/p5-Math-SimpleVariable/Makefile
new file mode 100644
index 00000000000..8a5be9b956f
--- /dev/null
+++ b/math/p5-Math-SimpleVariable/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Math::SimpleVariable
+# Date created: 5 Nov 2001
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SimpleVariable
+PORTVERSION= 0.03
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/fields.pm:${PORTSDIR}/devel/p5-Class-Fields
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::SimpleVariable.3
+
+pre-patch:
+ @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ '$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
+
+.include <bsd.port.mk>