aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile6
-rw-r--r--math/atlas/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index a5fe33e9345..e184cfa2e29 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -50,7 +50,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 42e8ddbf50b..a3a0fc74d80 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -49,7 +49,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"