aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/gambit/Makefile7
-rw-r--r--math/graphthing/Makefile5
2 files changed, 4 insertions, 8 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 51d52b168a7..2ee5a0f6817 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -15,14 +15,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A library of tools for doing computation in game theory
-LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
-
USE_X_PREFIX= yes
+USE_WX= 2.6
USE_GNOME= gnometarget gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
-MAKE_ENV= WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
CPPFLAGS= ${PTHREAD_CFLAGS}
diff --git a/math/graphthing/Makefile b/math/graphthing/Makefile
index e2be8a38f17..8e3b289df04 100644
--- a/math/graphthing/Makefile
+++ b/math/graphthing/Makefile
@@ -14,15 +14,14 @@ MASTER_SITES= http://graph.seul.org/
MAINTAINER= arved@FreeBSD.org
COMMENT= A tool that allows you to create, manipulate and study graphs
-LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
-
USE_BZIP2= yes
USE_GNOME= gnometarget gtk20
USE_BISON= yes
USE_GMAKE= yes
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.6-config
MAKEFILE= GNUmakefile
PLIST_FILES= bin/graphthing bin/gt