aboutsummaryrefslogtreecommitdiffstats
path: root/misc/logsurfer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/logsurfer/Makefile')
-rw-r--r--misc/logsurfer/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/logsurfer/Makefile b/misc/logsurfer/Makefile
new file mode 100644
index 00000000000..9040c36c2ab
--- /dev/null
+++ b/misc/logsurfer/Makefile
@@ -0,0 +1,30 @@
+# Created by: shanee@augusta.de
+# $FreeBSD$
+
+PORTNAME= logsurfer
+PORTVERSION= 1.8
+CATEGORIES= misc
+MASTER_SITES= http://www.crypt.gen.nz/logsurfer/ \
+ http://mirrors.rit.edu/zi/
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Process logfiles and conditionally perform certain actions
+
+LICENSE= BSD
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS+=--with-etcdir=${ETCDIR}
+USES= desthack
+USE_RC_SUBR= logsurfer
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>