aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-distutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/py-distutils/Makefile')
-rw-r--r--misc/py-distutils/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/misc/py-distutils/Makefile b/misc/py-distutils/Makefile
index bde72c696b6..35cf8746e43 100644
--- a/misc/py-distutils/Makefile
+++ b/misc/py-distutils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= distutils
-PORTVERSION= 0.9
+PORTVERSION= 0.9.1
CATEGORIES= misc python
MASTER_SITES= http://www.python.org/sigs/distutils-sig/download/
PKGNAMEPREFIX= py-
@@ -17,6 +17,10 @@ MAINTAINER= tg@FreeBSD.org
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
RUN_DEPENDS= python:${PORTSDIR}/lang/python
+PLIST_SUB= PYVERSION="python${PYVERSION}"
+
+PYVERSION!= python -c 'import string, sys; print string.split(sys.version)[0][:3]' || echo "1.5"
+
do-build:
@(cd ${WRKSRC}; python setup.py build)