aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kdenlive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/kdenlive/Makefile')
-rw-r--r--multimedia/kdenlive/Makefile40
1 files changed, 23 insertions, 17 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index fc66ffd7763..0108e80c71b 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -5,60 +5,66 @@
# $FreeBSD$
PORTNAME= kdenlive
-PORTVERSION= 0.7.8
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= multimedia kde
MASTER_SITES= SF
MAINTAINER= avilla@FreeBSD.org
-COMMENT= A professional quality non-linear video editing suite for KDE
+COMMENT= KDE professional quality non-linear video editing suite
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= mlt.3:${PORTSDIR}/multimedia/mlt
+LIB_DEPENDS= mlt.4:${PORTSDIR}/multimedia/mlt \
+ qjson.0:${PORTSDIR}/devel/qjson
USE_GETTEXT= yes
-USE_KDE4= automoc4 kdehier kdelibs kdeprefix sharedmime
+USE_KDE4= kdehier kdelibs kdeprefix automoc4 sharedmime
USE_QT_VER= 4
-QT_COMPONENTS= dbus gui network svg xml \
+QT_COMPONENTS= dbus gui network opengl script svg xml \
moc_build qmake_build rcc_build uic_build
-MAKE_JOBS_SAFE= yes
+USE_XORG= x11
USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
MAN1= kdenlive.1 kdenlive_render.1
OPTIONS= DVD "DVD creation with cdrtools and dvdauthor" on \
- FREI0R "Frei0r plugins" on \
+ FREI0R "frei0r plugins" on \
LADSPA "LADSPA plugins" on \
- SCREENGRAB "Screen capture with recordMyDesktop" on
+ SCREENGRAB "Screen capture with recordMyDesktop" on \
+ XINE "DVD preview with xine" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef(WITH_DVD)
+.ifndef(WITHOUT_DVD)
USE_CDRTOOLS= yes
RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
.endif
-.ifdef(WITH_FREI0R)
+.ifndef(WITHOUT_FREI0R)
RUN_DEPENDS+= frei0r-plugins>=0:${PORTSDIR}/graphics/frei0r-plugins
.endif
-.ifdef(WITH_LADSPA)
+.ifndef(WITHOUT_LADSPA)
RUN_DEPENDS+= swhplugins>=0:${PORTSDIR}/audio/swhplugins
.endif
-.ifdef(WITH_SCREENGRAB)
+.ifndef(WITHOUT_SCREENGRAB)
RUN_DEPENDS+= recordmydesktop:${PORTSDIR}/multimedia/recordmydesktop
.endif
+.ifndef(WITHOUT_XINE)
+RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
+.endif
+
post-patch:
- @${REINPLACE_CMD} -E -e '/${PORTNAME}.(menu|xpm)/d' \
+ ${REINPLACE_CMD} -E -e '/${PORTNAME}.(menu|xpm)/ d' \
${PATCH_WRKSRC}/data/CMakeLists.txt
- @${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \
${PATCH_WRKSRC}/src/mimetypes/CMakeLists.txt
post-install:
@-update-mime-database ${PREFIX}/share/mime
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>