aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libdvdnav/files
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/libdvdnav/files')
-rw-r--r--multimedia/libdvdnav/files/patch-example:Makefile.in11
-rw-r--r--multimedia/libdvdnav/files/patch-ltmain.sh49
-rw-r--r--multimedia/libdvdnav/files/patch-src:Makefile.in11
3 files changed, 71 insertions, 0 deletions
diff --git a/multimedia/libdvdnav/files/patch-example:Makefile.in b/multimedia/libdvdnav/files/patch-example:Makefile.in
new file mode 100644
index 00000000000..ca251d2042e
--- /dev/null
+++ b/multimedia/libdvdnav/files/patch-example:Makefile.in
@@ -0,0 +1,11 @@
+--- examples/Makefile.in.orig Tue May 21 01:52:35 2002
++++ examples/Makefile.in Tue May 21 01:52:51 2002
+@@ -116,7 +116,7 @@
+ LIBS = @LIBS@
+ menus_OBJECTS = menus.$(OBJEXT)
+ menus_DEPENDENCIES = $(top_builddir)/src/libdvdnav.la
+-menus_LDFLAGS =
++menus_LDFLAGS = $(THREAD_LIBS)
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
diff --git a/multimedia/libdvdnav/files/patch-ltmain.sh b/multimedia/libdvdnav/files/patch-ltmain.sh
new file mode 100644
index 00000000000..0591f6be269
--- /dev/null
+++ b/multimedia/libdvdnav/files/patch-ltmain.sh
@@ -0,0 +1,49 @@
+--- ltmain.sh.orig Mon Apr 29 18:30:38 2002
++++ ltmain.sh Tue May 21 01:46:02 2002
+@@ -958,6 +958,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -1045,14 +1046,14 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -2459,7 +2460,7 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
+ *)
+@@ -4247,10 +4248,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/libdvdnav/files/patch-src:Makefile.in b/multimedia/libdvdnav/files/patch-src:Makefile.in
new file mode 100644
index 00000000000..ee80996541b
--- /dev/null
+++ b/multimedia/libdvdnav/files/patch-src:Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Tue May 21 01:59:54 2002
++++ src/Makefile.in Tue May 21 02:00:14 2002
+@@ -102,7 +102,7 @@
+
+ libdvdnav_la_SOURCES = decoder.c dvdnav.c vm.c vmcmd.c read_cache.c navigation.c highlight.c searching.c settings.c
+
+-libdvdnav_la_LDFLAGS = $(DVDREAD_LIBS) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
++libdvdnav_la_LDFLAGS = $(DVDREAD_LIBS)
+
+
+ include_HEADERS = decoder.h dvdnav.h dvdnav_events.h dvdnav_internal.h vm.h vmcmd.h read_cache.h dvd_types.h