aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ogle
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/ogle')
-rw-r--r--multimedia/ogle/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/ogle/Makefile b/multimedia/ogle/Makefile
index 7e6363f3cff..5eee53996c7 100644
--- a/multimedia/ogle/Makefile
+++ b/multimedia/ogle/Makefile
@@ -54,6 +54,12 @@ pre-configure:
.include <bsd.port.pre.mk>
+# XXX due to gcc-3.4 (20040706) bug in preprocessing of inline functions,
+# this needs at least -O2 to compile. Fails with -O
+.if ${OSVERSION} >= 502126
+CFLAGS+= -O2
+.endif
+
# hack to make ogle work with liba52 + djbfft
.if exists(${LOCALBASE}/lib/liba52.la)
LIBA52_DEP_LIBS!= ${GREP} dependency_libs ${LOCALBASE}/lib/liba52.la | ${CUT} -d \' -f 2