aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/py-slackclient/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/py-slackclient/Makefile')
-rw-r--r--net-im/py-slackclient/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-im/py-slackclient/Makefile b/net-im/py-slackclient/Makefile
index b8f4d60825e..613133230ed 100644
--- a/net-im/py-slackclient/Makefile
+++ b/net-im/py-slackclient/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= slackclient
-PORTVERSION= 0.18.0
+PORTVERSION= 1.0.0
CATEGORIES= net-im python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
@@ -14,10 +13,18 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}websocket-client>0:${PORTSDIR}/www/py-websocket-client \
${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
USES= python:-2.7
+USE_GITHUB= yes
USE_PYTHON= autoplist distutils
+GH_ACCOUNT= slackhq
+GH_PROJECT= python-${PORTNAME}
+
NO_ARCH= yes
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
.include <bsd.port.mk>