aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ricochet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/ricochet/Makefile')
-rw-r--r--net-im/ricochet/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index 41b2c11192d..7732219cafb 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= ricochet
-PORTVERSION= 0.150620
+PORTVERSION= 1.1.2
+DISTVERSIONPREFIX= v
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@rawbw.com
@@ -18,11 +19,11 @@ RUN_DEPENDS= tor:${PORTSDIR}/security/tor
USE_GITHUB= yes
GH_ACCOUNT= ricochet-im
-GH_TAGNAME= e31a0fb
USES= compiler:c++11-lib gmake pkgconfig qmake
USE_OPENSSL= yes
-USE_QT5= core gui network quick quickcontrols widgets multimedia buildtools_build linguisttools_build
+USE_GL= gl
+USE_QT5= core gui network qml quick quickcontrols widgets multimedia buildtools_build linguisttools_build
QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${LOCALBASE}
PLIST_FILES= bin/ricochet \
@@ -30,4 +31,8 @@ PLIST_FILES= bin/ricochet \
share/icons/hicolor/48x48/apps/ricochet.png \
share/icons/hicolor/scalable/apps/ricochet.svg
+post-patch:
+ @${REINPLACE_CMD} -E 's| -fsanitize=[a-z-]+| |g' \
+ ${WRKSRC}/hardened.pri
+
.include <bsd.port.mk>