aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/sim-im/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/sim-im/Makefile')
-rw-r--r--net-im/sim-im/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-im/sim-im/Makefile b/net-im/sim-im/Makefile
index 7d17fe639a2..319b14cafdd 100644
--- a/net-im/sim-im/Makefile
+++ b/net-im/sim-im/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= simicq
-PORTVERSION= 0.8.2
+PORTVERSION= 0.8.3
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
@@ -18,17 +18,17 @@ USE_GMAKE= yes
USE_QT_VER= 3
USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
.else
CONFIGURE_ARGS+=--disable-openssl
.endif
-CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if defined(WITHOUT_KDE)
CONFIGURE_ARGS+= --disable-kde --enable-mt
-USE_REINPLACE= yes
.else
USE_KDELIBS_VER= 3
.endif
@@ -38,5 +38,6 @@ post-patch:
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
${WRKSRC}/configure
.endif
+ ${REINPLACE_CMD} -e 's/-O2//g' ${CONFIGURE_WRKSRC}/configure
.include <bsd.port.mk>