aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/seafile/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/seafile/files/patch-configure.ac')
-rw-r--r--net-mgmt/seafile/files/patch-configure.ac36
1 files changed, 19 insertions, 17 deletions
diff --git a/net-mgmt/seafile/files/patch-configure.ac b/net-mgmt/seafile/files/patch-configure.ac
index 49b00c1f33b..8ce4aed3f86 100644
--- a/net-mgmt/seafile/files/patch-configure.ac
+++ b/net-mgmt/seafile/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2015-01-21 22:45:28.000000000 -0500
-+++ configure.ac 2015-01-28 14:01:20.000000000 -0500
-@@ -50,8 +50,16 @@
+--- configure.ac.orig 2016-05-10 12:25:35 UTC
++++ configure.ac
+@@ -50,8 +50,16 @@ else
AC_MSG_RESULT(no)
fi
@@ -18,7 +18,7 @@
blinux=true
AC_MSG_RESULT(compile in linux)
else
-@@ -93,6 +101,11 @@
+@@ -93,6 +101,11 @@ if test "$bwin32" != true; then
[compile_fuse=$enableval],[compile_fuse="yes"])
fi
@@ -30,7 +30,7 @@
AC_ARG_ENABLE(client, AC_HELP_STRING([--enable-client], [enable client]),
[compile_client=$enableval],[compile_client="yes"])
-@@ -148,6 +161,7 @@
+@@ -148,6 +161,7 @@ AM_CONDITIONAL([COMPILE_FUSE], [test "${
AM_CONDITIONAL([WIN32], [test "$bwin32" = "true"])
AM_CONDITIONAL([MACOS], [test "$bmac" = "true"])
@@ -38,20 +38,20 @@
AM_CONDITIONAL([LINUX], [test "$blinux" = "true"])
-@@ -192,6 +206,9 @@
- LIB_PSAPI=-lpsapi
+@@ -193,6 +207,9 @@ if test "$bwin32" = true; then
LIB_MAC=
MSVC_CFLAGS="-D__MSVCRT__ -D__MSVCRT_VERSION__=0x0601"
+ LIB_CRYPT32=-lcrypt32
+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
elif test "$bmac" = true ; then
LIB_WS32=
LIB_GDI32=
-@@ -204,6 +221,24 @@
- LIB_PSAPI=
- MSVC_CFLAGS=
+@@ -207,6 +224,26 @@ elif test "$bmac" = true ; then
LIB_MAC="-framework CoreServices"
+ LIB_CRYPT32=
+ LIB_ICONV=-liconv
+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
@@ -67,23 +67,25 @@
+ LIB_PSAPI=
+ LIB_MAC=
+ MSVC_CFLAGS=
++ LIB_CRYPT32=
++ LIB_ICONV=-liconv
+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=-lkvm
else
LIB_WS32=
LIB_GDI32=
-@@ -216,6 +251,9 @@
- LIB_PSAPI=
+@@ -220,6 +257,9 @@ else
LIB_MAC=
MSVC_CFLAGS=
+ LIB_CRYPT32=
+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=
fi
AC_SUBST(LIB_WS32)
-@@ -228,6 +266,9 @@
+@@ -232,6 +272,9 @@ AC_SUBST(LIB_IPHLPAPI)
AC_SUBST(LIB_SHELL32)
AC_SUBST(LIB_PSAPI)
AC_SUBST(LIB_MAC)
@@ -91,9 +93,9 @@
+AC_SUBST(LIB_INOTIFY)
+AC_SUBST(LIB_KVM)
AC_SUBST(MSVC_CFLAGS)
-
-
-@@ -240,7 +281,9 @@
+ AC_SUBST(LIB_CRYPT32)
+ AC_SUBST(LIB_ICONV)
+@@ -246,7 +289,9 @@ ZDB_REQUIRED=2.10
#LIBNAUTILUS_EXTENSION_REQUIRED=2.30.1
CURL_REQUIRED=7.17
FUSE_REQUIRED=2.7.3
@@ -103,7 +105,7 @@
PKG_CHECK_MODULES(SSL, [openssl])
AC_SUBST(SSL_CFLAGS)
-@@ -270,9 +313,11 @@
+@@ -276,9 +321,11 @@ PKG_CHECK_MODULES(LIBEVENT, [libevent >=
AC_SUBST(LIBEVENT_CFLAGS)
AC_SUBST(LIBEVENT_LIBS)