aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-twistedWords/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-twistedWords/Makefile')
-rw-r--r--net/py-twistedWords/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/py-twistedWords/Makefile b/net/py-twistedWords/Makefile
new file mode 100644
index 00000000000..ee3a328310b
--- /dev/null
+++ b/net/py-twistedWords/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-twistedWords
+# Date created: 14 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twistedWords
+PORTVERSION= 0.1.0
+CATEGORIES= net devel python
+MASTER_SITES= http://twistedmatrix.com/downloads/Words/0.1/ \
+ http://tmrc.mit.edu/mirror/twisted/Words/0.1/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedWords-${PORTVERSION}
+
+MAINTAINER= neal@nelson.name
+COMMENT= Twisted Words has more chat than you can handle
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+
+WRKSRC= ${WRKDIR}/TwistedWords-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB+= S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+.include <bsd.port.mk>
301-1/+0 * - Convert to new perl frameworkmat2013-08-031-1/+2