aboutsummaryrefslogtreecommitdiffstats
path: root/net/pygopherd/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/pygopherd/files')
-rw-r--r--net/pygopherd/files/patch-pygopherd11
-rw-r--r--net/pygopherd/files/patch-pygopherd.811
-rw-r--r--net/pygopherd/files/patch-pygopherd.conf11
-rw-r--r--net/pygopherd/files/patch-setup.py11
4 files changed, 44 insertions, 0 deletions
diff --git a/net/pygopherd/files/patch-pygopherd b/net/pygopherd/files/patch-pygopherd
new file mode 100644
index 00000000000..e87b5a39e9b
--- /dev/null
+++ b/net/pygopherd/files/patch-pygopherd
@@ -0,0 +1,11 @@
+--- bin/pygopherd.orig Sun Sep 8 02:58:15 2002
++++ bin/pygopherd Fri Aug 9 01:59:33 2002
+@@ -24,7 +24,7 @@
+ from pygopherd import *
+ import sys
+
+-conffile = '/etc/pygopherd/pygopherd.conf'
++conffile = '%%PREFIX%%/etc/pygopherd/pygopherd.conf'
+ if len(sys.argv) > 1:
+ conffile = sys.argv[1]
+
diff --git a/net/pygopherd/files/patch-pygopherd.8 b/net/pygopherd/files/patch-pygopherd.8
new file mode 100644
index 00000000000..b50e5b799ac
--- /dev/null
+++ b/net/pygopherd/files/patch-pygopherd.8
@@ -0,0 +1,11 @@
+--- pygopherd.8.orig Sun Sep 8 03:02:36 2002
++++ pygopherd.8 Sun Sep 8 03:02:51 2002
+@@ -188,7 +188,7 @@
+ .B python2.2.
+
+ Next, proceed to configuration. Make sure that the
+-\fI/etc/pygopherd/pygopherd.conf\fP file names valid users
++\fI%%PREFIX%%/etc/pygopherd/pygopherd.conf\fP file names valid users
+ (\fBsetuid\fP and \fBsetgid\fP options) and a valid document root
+ (\fBroot\fP option).
+
diff --git a/net/pygopherd/files/patch-pygopherd.conf b/net/pygopherd/files/patch-pygopherd.conf
new file mode 100644
index 00000000000..09a5cff6abe
--- /dev/null
+++ b/net/pygopherd/files/patch-pygopherd.conf
@@ -0,0 +1,11 @@
+--- conf/pygopherd.conf.orig Sun Sep 8 03:00:01 2002
++++ conf/pygopherd.conf Sun Sep 8 03:00:34 2002
+@@ -119,7 +119,7 @@
+ # specify multiple files here -- just separate them with a colon.
+ # ALL of them that are found will be read.
+
+-mimetypes = ./conf/mime.types:/etc/pygopherd/mime.types:/etc/mime.types
++mimetypes = ./conf/mime.types:%%PREFIX%%/etc/pygopherd/mime.types:/etc/mime.types
+
+ # Encodings. You can use the default with the following syntax. The
+ # mimetypex.encodings_map is {'.Z': 'compress', '.gz': 'gzip'}.
diff --git a/net/pygopherd/files/patch-setup.py b/net/pygopherd/files/patch-setup.py
new file mode 100644
index 00000000000..ff32df5d3b3
--- /dev/null
+++ b/net/pygopherd/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Sun Sep 8 02:47:43 2002
++++ setup.py Sun Sep 8 02:48:06 2002
+@@ -34,7 +34,7 @@
+ url = pygopherd.version.homepage,
+ packages = ['pygopherd', 'pygopherd.handlers', 'pygopherd.protocols'],
+ scripts = ['bin/pygopherd'],
+- data_files = [ ('/etc/pygopherd', ['conf/pygopherd.conf',
++ data_files = [ ('%%PREFIX%%/etc/pygopherd', ['conf/pygopherd.conf',
+ 'conf/mime.types'] ) ],
+ license = pygopherd.version.license
+ )