aboutsummaryrefslogtreecommitdiffstats
path: root/net/rsync
diff options
context:
space:
mode:
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile4
-rw-r--r--net/rsync/files/patch-2.6.8-unexpected_tag_312
2 files changed, 7 insertions, 9 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 87a6a1d8187..1de2f77b1b3 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -28,6 +28,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
--with-rsyncd-conf=${PREFIX}/etc/rsyncd.conf
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PATCH_STRIP= -p1
.if !defined(NOPORTDOCS)
PORTDOCS= NEWS README csprotocol.txt tech_report.tex
@@ -54,18 +55,15 @@ CONFIGURE_ARGS+= --with-included-popt
.if !defined(WITHOUT_TIMELIMIT)
EXTRA_PATCHES+= ${WRKSRC}/patches/time-limit.diff
-PATCH_STRIP= -p1
.endif
.if !defined(WITHOUT_FLAGS)
EXTRA_PATCHES+= ${WRKSRC}/patches/flags.diff
-PATCH_STRIP= -p1
.endif
.if !defined(WITHOUT_ACLS)
.if ${OSVERSION} >= 500000
EXTRA_PATCHES+= ${WRKSRC}/patches/acls.diff
-PATCH_STRIP= -p1
CONFIGURE_ARGS+=--enable-acl-support
.endif
.endif
diff --git a/net/rsync/files/patch-2.6.8-unexpected_tag_3 b/net/rsync/files/patch-2.6.8-unexpected_tag_3
index c00ca4a11a9..e7073ab3392 100644
--- a/net/rsync/files/patch-2.6.8-unexpected_tag_3
+++ b/net/rsync/files/patch-2.6.8-unexpected_tag_3
@@ -3,8 +3,8 @@ RCS file: /cvsroot/rsync/io.c,v
retrieving revision 1.195
retrieving revision 1.196
diff -u -r1.195 -r1.196
---- rsync/io.c 2006/05/03 06:32:59 1.195
-+++ rsync/io.c 2006/05/03 16:17:46 1.196
+--- io.c 2006/05/03 06:32:59 1.195
++++ io.c 2006/05/03 16:17:46 1.196
@@ -282,10 +282,7 @@
exit_cleanup(RERR_STREAMIO);
}
@@ -69,8 +69,8 @@ RCS file: /cvsroot/rsync/log.c,v
retrieving revision 1.147
retrieving revision 1.148
diff -u -r1.147 -r1.148
---- rsync/log.c 2006/05/03 06:11:11 1.147
-+++ rsync/log.c 2006/05/03 16:17:49 1.148
+--- log.c 2006/05/03 06:11:11 1.147
++++ log.c 2006/05/03 16:17:49 1.148
@@ -256,7 +256,7 @@
if (am_server) {
@@ -85,8 +85,8 @@ RCS file: /cvsroot/rsync/proto.h,v
retrieving revision 1.303
retrieving revision 1.304
diff -u -r1.303 -r1.304
---- rsync/proto.h 2006/05/03 00:48:17 1.303
-+++ rsync/proto.h 2006/05/03 16:17:42 1.304
+--- proto.h 2006/05/03 00:48:17 1.303
++++ proto.h 2006/05/03 16:17:42 1.304
@@ -104,7 +104,7 @@
void set_msg_fd_out(int fd);
void increment_active_files(int ndx, int itemizing, enum logcode code);