aboutsummaryrefslogtreecommitdiffstats
path: root/net/ss5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ss5/Makefile')
-rw-r--r--net/ss5/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/ss5/Makefile b/net/ss5/Makefile
new file mode 100644
index 00000000000..934e4477422
--- /dev/null
+++ b/net/ss5/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ss5
+# Date created: 25 August 2006
+# Whom: Raffaele De Lorenzo - raffaele.delorenzo@libero.it
+#
+# $FreeBSD$
+#
+
+PORTNAME= ss5
+PORTVERSION= 3.6.1
+CATEGORIES= net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ss5
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+
+MAINTAINER= raffaele.delorenzo@libero.it
+COMMENT= SOCKS v4/v5 application layer gateway with many features
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_OPENLDAP= yes
+USE_RC_SUBR= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-binpathbase=${PREFIX}/sbin \
+ --with-docpathbase=${PREFIX}/share/doc \
+ --with-confpathbase=${PREFIX}/etc \
+ --with-libpath=${PREFIX}/lib
+
+MAKE_ENV= DATADIR=${DATADIR} EXAMPLESDIR=${EXAMPLESDIR}
+
+MAN1= ss5.1
+MAN5= ss5.conf.5 ss5.pam.5 ss5.passwd.5 ss5.peers.5
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's,/usr/local/etc/opt/ss5,${PREFIX}/etc/ss5,' \
+ ${WRKSRC}/include/config.h.in
+
+.include <bsd.port.mk>