aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/nam/Makefile8
-rw-r--r--net/ns/Makefile4
-rw-r--r--net/ns2/Makefile4
3 files changed, 15 insertions, 1 deletions
diff --git a/net/nam/Makefile b/net/nam/Makefile
index 8810185c1f8..5bf73e9c7fc 100644
--- a/net/nam/Makefile
+++ b/net/nam/Makefile
@@ -27,6 +27,12 @@ CONFIGURE_ARGS= --with-tcl-ver=8.4 --with-tk-ver=8.4
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= # empty
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64"
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,friend Queue,friend class Queue,' ${WRKSRC}/queue.h
@@ -38,4 +44,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ex/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/ns/Makefile b/net/ns/Makefile
index 8c872b33d61..628f90073fd 100644
--- a/net/ns/Makefile
+++ b/net/ns/Makefile
@@ -30,6 +30,10 @@ ALL_TARGET=
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/net/ns2/Makefile b/net/ns2/Makefile
index 8c872b33d61..628f90073fd 100644
--- a/net/ns2/Makefile
+++ b/net/ns2/Makefile
@@ -30,6 +30,10 @@ ALL_TARGET=
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1