aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/activemq/Makefile3
-rw-r--r--net/bwping/Makefile3
-rw-r--r--net/cyphesis/Makefile3
-rw-r--r--net/dhcprelya/Makefile3
-rw-r--r--net/exabgp/Makefile3
-rw-r--r--net/fping/Makefile3
-rw-r--r--net/get_iplayer/Makefile2
-rw-r--r--net/heybuddy/Makefile3
-rw-r--r--net/htpdate/Makefile2
-rw-r--r--net/ipgrab/Makefile3
-rw-r--r--net/jwhois/Makefile3
-rw-r--r--net/libnet10/Makefile2
-rw-r--r--net/librouteros/Makefile2
-rw-r--r--net/opennx/Makefile3
-rw-r--r--net/pchar/Makefile3
-rw-r--r--net/pmf/Makefile3
-rw-r--r--net/ptpd2/Makefile2
-rw-r--r--net/pure-sockets/Makefile2
-rw-r--r--net/raggle/Makefile2
-rw-r--r--net/ripe-whois/Makefile2
-rw-r--r--net/samplicator/Makefile2
-rw-r--r--net/sharity-light/Makefile3
-rw-r--r--net/skstream/Makefile3
-rw-r--r--net/smb4k-kde4/Makefile3
-rw-r--r--net/spoofer/Makefile2
-rw-r--r--net/tcpreen/Makefile3
-rw-r--r--net/tcpsplit/Makefile2
-rw-r--r--net/tinyldap/Makefile2
-rw-r--r--net/u6rd/Makefile2
-rw-r--r--net/uplog/Makefile2
-rw-r--r--net/wmnetload/Makefile3
31 files changed, 79 insertions, 0 deletions
diff --git a/net/activemq/Makefile b/net/activemq/Makefile
index 4db34c21768..27df99d328c 100644
--- a/net/activemq/Makefile
+++ b/net/activemq/Makefile
@@ -65,6 +65,9 @@ PLIST_SUB= MQUSER="${MQUSER}" \
JETTYVERSION="${JETTYVERSION}" \
LVDBVERSION="${LVDBVERSION}" \
LVDBJNIVERSION="${LVDBJNIVERSION}"
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/bwping/Makefile b/net/bwping/Makefile
index 169db1af3c7..3df9872f4e9 100644
--- a/net/bwping/Makefile
+++ b/net/bwping/Makefile
@@ -17,6 +17,9 @@ MAN8= bwping.8
PLIST_FILES= sbin/bwping
NO_STAGE= yes
+
+OPTIONS_DEFINE= IPV6
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIPV6}
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index f7d2790d6b8..5107023e542 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -34,6 +34,9 @@ MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
cyconvertrules.1 cydumprules.1 cyloadrules.1 cypasswd.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/net/dhcprelya/Makefile b/net/dhcprelya/Makefile
index 329188187a8..2d9641a2a86 100644
--- a/net/dhcprelya/Makefile
+++ b/net/dhcprelya/Makefile
@@ -27,6 +27,9 @@ PLIST_FILES= sbin/${PORTNAME} lib/${PORTNAME}_log_plugin.so \
RADIUS_PLUGIN_PLUGIN_DESC= build radius plugin
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MRADIUS_PLUGIN}
diff --git a/net/exabgp/Makefile b/net/exabgp/Makefile
index f23e02165c9..c42e6702087 100644
--- a/net/exabgp/Makefile
+++ b/net/exabgp/Makefile
@@ -29,6 +29,9 @@ GROUPS= _bgpd
MAN1= ${PORTNAME}.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= EXAMPLES
+
.include <bsd.port.options.mk>
post-extract:
diff --git a/net/fping/Makefile b/net/fping/Makefile
index d1b48b246bb..0c6ac8bc824 100644
--- a/net/fping/Makefile
+++ b/net/fping/Makefile
@@ -19,6 +19,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/sbin"
NO_STAGE= yes
+
+OPTIONS_DEFINE= IPV6
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIPV4}
diff --git a/net/get_iplayer/Makefile b/net/get_iplayer/Makefile
index e26840c415d..0cc192abc31 100644
--- a/net/get_iplayer/Makefile
+++ b/net/get_iplayer/Makefile
@@ -40,6 +40,8 @@ PORTDATA= html plugins
PORTDOCS= CHANGELOG-get_iplayer.cgi.txt CHANGELOG.txt \
README-get_iplayer.cgi.txt README.md web.sh
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/net/heybuddy/Makefile b/net/heybuddy/Makefile
index c067dfd2f22..809f81d4626 100644
--- a/net/heybuddy/Makefile
+++ b/net/heybuddy/Makefile
@@ -25,6 +25,9 @@ DESKTOP_ENTRIES= "Heybuddy" \
false
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index 8111793b2fa..2d85fce37ae 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -20,6 +20,8 @@ PLIST_FILES= bin/${PORTNAME} man/man8/${PORTNAME}.8.gz
PORTDOCS= Changelog README
USE_RC_SUBR= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/ipgrab/Makefile b/net/ipgrab/Makefile
index 8fe8700ea5b..d66635f3fcd 100644
--- a/net/ipgrab/Makefile
+++ b/net/ipgrab/Makefile
@@ -24,6 +24,9 @@ PORTDOCS= README AUTHORS COPYING ChangeLog DEVELOPER-HOWTO \
INSTALL NEWS TODO
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index 3293ac69c82..b57c89eeb8d 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -20,6 +20,9 @@ LDFLAGS+= -L${PREFIX}/lib
CONFIGURE_ARGS= --localstatedir=${PREFIX}/var/jwhois
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/net/libnet10/Makefile b/net/libnet10/Makefile
index 605ee61ddc8..d112ebcacd1 100644
--- a/net/libnet10/Makefile
+++ b/net/libnet10/Makefile
@@ -20,6 +20,8 @@ USE_AUTOTOOLS= autoconf
WRKSRC= ${WRKDIR}/Libnet-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/net/librouteros/Makefile b/net/librouteros/Makefile
index d9fb547bb5d..6f9d8ac6885 100644
--- a/net/librouteros/Makefile
+++ b/net/librouteros/Makefile
@@ -24,6 +24,8 @@ CFLAGS+= -I${LOCALBASE}/include -Wno-error
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/net/opennx/Makefile b/net/opennx/Makefile
index 7fd0b7bb886..29e2353cf27 100644
--- a/net/opennx/Makefile
+++ b/net/opennx/Makefile
@@ -37,6 +37,9 @@ NO_PACKAGE= must generate a fresh private key at install time
SSH_KEYGEN?= ssh-keygen
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MNLS}
diff --git a/net/pchar/Makefile b/net/pchar/Makefile
index 7ea78b17961..277e8a56ad0 100644
--- a/net/pchar/Makefile
+++ b/net/pchar/Makefile
@@ -25,6 +25,9 @@ PLIST_FILES= sbin/pchar
PORTDOCS= README CHANGES FAQ
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/net/pmf/Makefile b/net/pmf/Makefile
index 873a4312f8a..529d3313c61 100644
--- a/net/pmf/Makefile
+++ b/net/pmf/Makefile
@@ -20,6 +20,9 @@ SUB_FILES= pmfrc.default
CFLAGS+= -Wno-return-type
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/ptpd2/Makefile b/net/ptpd2/Makefile
index db3c2d3eada..547fe9a694f 100644
--- a/net/ptpd2/Makefile
+++ b/net/ptpd2/Makefile
@@ -26,6 +26,8 @@ PORTDOCS= *
USE_RC_SUBR= ptpd2
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
run-autotools: run-autotools-autoreconf
diff --git a/net/pure-sockets/Makefile b/net/pure-sockets/Makefile
index b6e162eea06..c3cd8dd10d4 100644
--- a/net/pure-sockets/Makefile
+++ b/net/pure-sockets/Makefile
@@ -25,6 +25,8 @@ PORTDOCS= README
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/net/raggle/Makefile b/net/raggle/Makefile
index e0ee8f3e8f9..9eb4c602ae5 100644
--- a/net/raggle/Makefile
+++ b/net/raggle/Makefile
@@ -21,6 +21,8 @@ DOCS= AUTHORS BUGS COPYING ChangeLog README TODO \
doc/default_config.rb doc/pauls_feeds.opml.gz \
doc/theme_documentation.txt
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/ripe-whois/Makefile b/net/ripe-whois/Makefile
index 0576869981a..57b01abc80c 100644
--- a/net/ripe-whois/Makefile
+++ b/net/ripe-whois/Makefile
@@ -22,6 +22,8 @@ post-patch::
-e '/^bin_PROGRAMS =/ s/whois\$$\(EXEEXT\)/whois3$$(EXEEXT)/' \
${WRKSRC}/Makefile.in
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/net/samplicator/Makefile b/net/samplicator/Makefile
index e2d34366f0e..6c92643530b 100644
--- a/net/samplicator/Makefile
+++ b/net/samplicator/Makefile
@@ -18,6 +18,8 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/samplicate
PORTDOCS= NEWS README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/sharity-light/Makefile b/net/sharity-light/Makefile
index 6b2d2967344..72766c1551c 100644
--- a/net/sharity-light/Makefile
+++ b/net/sharity-light/Makefile
@@ -16,6 +16,9 @@ PLIST_FILES= sbin/shlight sbin/unshlight
PORTDOCS= *
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-extract:
diff --git a/net/skstream/Makefile b/net/skstream/Makefile
index 6ecaf0ca806..09a77efc8fe 100644
--- a/net/skstream/Makefile
+++ b/net/skstream/Makefile
@@ -16,6 +16,9 @@ USE_LDCONFIG= yes
USE_GCC= 4.7+
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index 3af76be0bd0..4d9e04da6fb 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -27,6 +27,9 @@ DOCSDIR= ${PREFIX}/share/doc/HTML/en/smb4k
SUB_FILES= pkg-message
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/net/spoofer/Makefile b/net/spoofer/Makefile
index 370140fdb72..b788c8fbda9 100644
--- a/net/spoofer/Makefile
+++ b/net/spoofer/Makefile
@@ -14,6 +14,8 @@ PORTDOCS= README CHANGES
HAS_CONFIGURE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/tcpreen/Makefile b/net/tcpreen/Makefile
index 236b91b8056..9e7b5834ad2 100644
--- a/net/tcpreen/Makefile
+++ b/net/tcpreen/Makefile
@@ -17,6 +17,9 @@ MAN1= tcpreen.1
DOC_FILES= AUTHORS NEWS README THANKS TODO
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/net/tcpsplit/Makefile b/net/tcpsplit/Makefile
index ab2bb9c2339..499b5264608 100644
--- a/net/tcpsplit/Makefile
+++ b/net/tcpsplit/Makefile
@@ -18,6 +18,8 @@ NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -E '/^(CC|CFLAGS|INC|LD)/d' ${WRKSRC}/Makefile
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/net/tinyldap/Makefile b/net/tinyldap/Makefile
index 98b4a670bcc..a125ba311f1 100644
--- a/net/tinyldap/Makefile
+++ b/net/tinyldap/Makefile
@@ -29,6 +29,8 @@ DOCFILES= ACL FORMAT GETTING.STARTED README README.security RFCs \
LIBOWFAT_PORT?= devel/libowfat
TINYLDAP_DATA?= ${PREFIX}/tinyldap/data
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/net/u6rd/Makefile b/net/u6rd/Makefile
index d82da19c31f..49f6ce6c134 100644
--- a/net/u6rd/Makefile
+++ b/net/u6rd/Makefile
@@ -16,6 +16,8 @@ USE_RC_SUBR= u6rd
PLIST_FILES= sbin/u6rd man/man8/u6rd.8.gz
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/net/uplog/Makefile b/net/uplog/Makefile
index d4f85aa1827..f0a90037c22 100644
--- a/net/uplog/Makefile
+++ b/net/uplog/Makefile
@@ -16,6 +16,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
PORTDOCS= README
PLIST_FILES= bin/uplog
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/net/wmnetload/Makefile b/net/wmnetload/Makefile
index 158f7189f82..d6177a71436 100644
--- a/net/wmnetload/Makefile
+++ b/net/wmnetload/Makefile
@@ -19,6 +19,9 @@ USE_XORG= xpm x11
GNU_CONFIGURE= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install: