aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/giftoxic/Makefile28
-rw-r--r--net/giftoxic/distinfo1
-rw-r--r--net/giftoxic/files/patch-src-gtkcellrendererprogress.c40
-rw-r--r--net/giftoxic/files/patch-src-utils.c22
-rw-r--r--net/giftoxic/pkg-descr7
-rw-r--r--net/giftoxic/pkg-plist8
7 files changed, 107 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9019041f06c..412f83a6326 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -168,6 +168,7 @@
SUBDIR += gift-gnutella
SUBDIR += gift-openft
SUBDIR += giftcurs
+ SUBDIR += giftoxic
SUBDIR += gini
SUBDIR += ginsu
SUBDIR += gkrellm_snmp
diff --git a/net/giftoxic/Makefile b/net/giftoxic/Makefile
new file mode 100644
index 00000000000..e879e5906ee
--- /dev/null
+++ b/net/giftoxic/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: giFToxic
+# Date Created: 23 December 2003
+# Whom: Joel Diaz <joeldiaz@bellsouth.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFToxic
+PORTVERSION= 0.0.9
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= giftoxic
+
+MAINTAINER= joeldiaz@bellsouth.net
+COMMENT= GTK2 client for giFT
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+USE_X_PREFIX= yes
+USE_GETOPT_LONG= yes
+USE_GNOME= gtk20 gnomeprefix gnomehack
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-included-gettext
+
+.include <bsd.port.mk>
diff --git a/net/giftoxic/distinfo b/net/giftoxic/distinfo
new file mode 100644
index 00000000000..c5b596d85a7
--- /dev/null
+++ b/net/giftoxic/distinfo
@@ -0,0 +1 @@
+MD5 (giFToxic-0.0.9.tar.gz) = 66fe05d5d34cf08d310886784682136f
diff --git a/net/giftoxic/files/patch-src-gtkcellrendererprogress.c b/net/giftoxic/files/patch-src-gtkcellrendererprogress.c
new file mode 100644
index 00000000000..e413f7045d3
--- /dev/null
+++ b/net/giftoxic/files/patch-src-gtkcellrendererprogress.c
@@ -0,0 +1,40 @@
+--- src/gtkcellrendererprogress.c.orig Thu May 22 06:23:39 2003
++++ src/gtkcellrendererprogress.c Sun Dec 28 14:28:27 2003
+@@ -370,7 +370,13 @@
+ */
+ GdkGC *gc;
+ gint draw_width;
+-
++
++ PangoFontDescription *font;
++
++ PangoContext *context;
++ PangoLayout *layout;
++ gchar *text;
++ int w,h;
+
+ if ((flags & GTK_CELL_RENDERER_SELECTED) == GTK_CELL_RENDERER_SELECTED)
+ {
+@@ -425,18 +431,17 @@
+
+
+
+- PangoFontDescription *font = pango_font_description_from_string ("8");
++ font = pango_font_description_from_string ("8");
+
+- PangoContext *context = gtk_widget_create_pango_context(widget);
+- PangoLayout *layout = pango_layout_new(context);
++ context = gtk_widget_create_pango_context(widget);
++ layout = pango_layout_new(context);
+
+ pango_layout_set_font_description (layout, font);
+- gchar *text = g_strdup_printf("%.1f%%",cellprogress->priv->value);
++ text = g_strdup_printf("%.1f%%",cellprogress->priv->value);
+ pango_layout_set_text(layout, text, -1);
+
+ gdk_gc_set_rgb_fg_color (gc, &cellprogress->priv->text_color);
+
+- int w,h;
+ pango_layout_get_pixel_size(layout, &w, &h);
+ w = (cell_area->width - w)/2;
+ h = (cell_area->height - h)/2;
diff --git a/net/giftoxic/files/patch-src-utils.c b/net/giftoxic/files/patch-src-utils.c
new file mode 100644
index 00000000000..13fe72ad34f
--- /dev/null
+++ b/net/giftoxic/files/patch-src-utils.c
@@ -0,0 +1,22 @@
+--- src/utils.c.orig Tue May 27 21:37:18 2003
++++ src/utils.c Sun Dec 28 14:25:22 2003
+@@ -366,6 +366,8 @@
+
+ gulong divisor = 1;
+ gint type = 0;
++ gulong mod;
++ gulong nice;
+
+ if (size >= 1000000){
+ divisor = 1000000;
+@@ -375,8 +377,8 @@
+ type = 1;
+ }
+
+- gulong mod = size % divisor;
+- gulong nice = size / divisor;
++ mod = size % divisor;
++ nice = size / divisor;
+ strcpy(format, (mod == 0)?"%.0f":"%.2f");
+ strcat(format, (nice == 1 && mod == 0?gettext(qtys[type][0]):gettext(qtys[type][1])));
+ return g_strdup_printf(format, (gfloat) size / divisor);
diff --git a/net/giftoxic/pkg-descr b/net/giftoxic/pkg-descr
new file mode 100644
index 00000000000..28c6cea2a23
--- /dev/null
+++ b/net/giftoxic/pkg-descr
@@ -0,0 +1,7 @@
+giFToxic is a GTK2 based client for giFT which allows you to search and
+download from Gnutella, FastTrack and OpenFT networks.
+
+WWW: http://giftoxic.sourceforge.net
+
+- Joel
+joeldiaz@bellsouth.net
diff --git a/net/giftoxic/pkg-plist b/net/giftoxic/pkg-plist
new file mode 100644
index 00000000000..a570dc6a9ff
--- /dev/null
+++ b/net/giftoxic/pkg-plist
@@ -0,0 +1,8 @@
+bin/giFToxic
+share/gnome/applications/giFToxic.desktop
+share/gnome/giFToxic/logo.png
+share/gnome/pixmaps/giFToxic-48.png
+share/locale/de/LC_MESSAGES/giFToxic.mo
+share/locale/es/LC_MESSAGES/giFToxic.mo
+share/locale/nl/LC_MESSAGES/giFToxic.mo
+@dirrm share/gnome/giFToxic