aboutsummaryrefslogtreecommitdiffstats
path: root/news/p5-News-Article/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/p5-News-Article/Makefile')
-rw-r--r--news/p5-News-Article/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 2d2fd8a91ed..b2f92c787e2 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -7,7 +7,7 @@
PORTNAME= News-Article
PORTVERSION= 1.27
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= News
@@ -16,9 +16,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Object for handling Usenet articles in mail or news form
+BUILD_DEPENDS= ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+
PERL_CONFIGURE= yes
MAN3= News::Article.3 News::AutoReply.3 News::FormArticle.3 \
News::FormReply.3
-.include <bsd.port.mk>
+OPTIONS= PGP_SIGN "PGP::Sign support for header signing" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PGP_SIGN)
+BUILD_DEPENDS+= ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+RUN_DEPENDS+= ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+.endif
+
+.include <bsd.port.post.mk>