aboutsummaryrefslogtreecommitdiffstats
path: root/palm/pilot-link/files
diff options
context:
space:
mode:
Diffstat (limited to 'palm/pilot-link/files')
-rw-r--r--palm/pilot-link/files/patch-aa29
-rw-r--r--palm/pilot-link/files/patch-af30
-rw-r--r--palm/pilot-link/files/patch-ag11
-rw-r--r--palm/pilot-link/files/patch-ah11
-rw-r--r--palm/pilot-link/files/patch-ai11
-rw-r--r--palm/pilot-link/files/patch-aj11
-rw-r--r--palm/pilot-link/files/patch-ak12
-rw-r--r--palm/pilot-link/files/patch-getopt14
-rw-r--r--palm/pilot-link/files/patch-iconv7
9 files changed, 24 insertions, 112 deletions
diff --git a/palm/pilot-link/files/patch-aa b/palm/pilot-link/files/patch-aa
index cd68196bf5e..da18b7fbaa3 100644
--- a/palm/pilot-link/files/patch-aa
+++ b/palm/pilot-link/files/patch-aa
@@ -1,16 +1,13 @@
---- Makefile.in Tue Oct 7 07:55:21 1997
-+++ Makefile.in Mon Nov 24 00:13:27 1997
-@@ -15,11 +15,11 @@
- PURIFY =
-
- # Libraries needed to link with Tcl & (optionally) Tk
--TCLTK_LIBS = @TCLTKLIBS@
-+TCLTK_LIBS = -L/usr/lib @TCLTKLIBS@
- # Include directives needed to compile with Tcl & Tk, and
- # -DTCL if Tcl is available, and
- # -DTK if Tk is available.
--TCLTK_FLAGS = @TCLTKFLAGS@
-+TCLTK_FLAGS = @TCLTKFLAGS@ -I/usr/X11R6/include
-
- # Libraries needed to link with GNU readline
- RLLIBS = @RLLIBS@
+--- Makefile.in.orig Thu Mar 21 07:31:21 2002
++++ Makefile.in Wed Mar 27 12:33:16 2002
+@@ -100,8 +100,8 @@
+ TCLLIBS = @TCLLIBS@
+ TCLTKFLAGS = @TCLTKFLAGS@
+ TCLTKLIBS = @TCLTKLIBS@
+-TCLTK_FLAGS = @TCLTK_FLAGS@
+-TCLTK_LIBS = @TCLTK_LIBS@
++TCLTK_FLAGS = @TCLTK_FLAGS@ -I/usr/X11R6/include
++TCLTK_LIBS = -L/usr/lib @TCLTK_LIBS@
+ TCL_BIN = @TCL_BIN@
+ TCL_INC = @TCL_INC@
+ TCL_LIBS = @TCL_LIBS@
diff --git a/palm/pilot-link/files/patch-af b/palm/pilot-link/files/patch-af
index bb23f83ce9f..c090a96c5df 100644
--- a/palm/pilot-link/files/patch-af
+++ b/palm/pilot-link/files/patch-af
@@ -1,19 +1,11 @@
-*** pilot-mail.c.orig Sun Oct 10 23:57:07 1999
---- pilot-mail.c Sun Oct 10 23:57:34 1999
-***************
-*** 15,21 ****
- #define POPUSER ""
- #define POPPASS ""
- #define PILOTFROM ""
-! #define SENDMAIL "/usr/lib/sendmail -t -i"
- #define POPKEEP "keep"
- #define DISPOSE "keep"
- #define TOPILOT_MHDIR ""
---- 15,21 ----
- #define POPUSER ""
- #define POPPASS ""
- #define PILOTFROM ""
-! #define SENDMAIL "/usr/sbin/sendmail -t -i"
- #define POPKEEP "keep"
- #define DISPOSE "keep"
- #define TOPILOT_MHDIR ""
+--- src/pilot-mail.c.orig Fri Mar 1 23:13:57 2002
++++ src/pilot-mail.c Wed Mar 27 12:34:36 2002
+@@ -252,7 +252,7 @@
+ *pop_host = getvars("POPHOST", ""),
+ *pop_user = getvars("POPUSER", ""),
+ *pop_pass = getvars("POPPASS", ""),
+- *sendmail = getvars("SENDMAIL", "/usr/lib/sendmail -t -i"),
++ *sendmail = getvars("SENDMAIL", "/usr/sbin/sendmail -t -i"),
+ *pop_keep = getvars("POPKEEP", "keep"),
+ *pilot_dispose = getvars("PILOTDISPOSE", "keep"),
+ *topilot_mhdir = getvars("TOPILOT_MHDIR", "");
diff --git a/palm/pilot-link/files/patch-ag b/palm/pilot-link/files/patch-ag
deleted file mode 100644
index d19c4a01f16..00000000000
--- a/palm/pilot-link/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/pi-address.hxx.kan Mon Jun 17 16:34:24 2002
-+++ ./include/pi-address.hxx Mon Jun 17 16:35:08 2002
-@@ -33,7 +33,7 @@
-
- char *_entry[19];
-
-- friend addressList_t;
-+ friend class addressList_t;
-
- address_t *_next;
-
diff --git a/palm/pilot-link/files/patch-ah b/palm/pilot-link/files/patch-ah
deleted file mode 100644
index 3c9d0eef708..00000000000
--- a/palm/pilot-link/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/pi-datebook.hxx.kan Mon Jun 17 16:34:24 2002
-+++ ./include/pi-datebook.hxx Mon Jun 17 16:35:16 2002
-@@ -34,7 +34,7 @@
- };
-
- private:
-- friend appointmentList_t;
-+ friend class appointmentList_t;
-
- tm _begin; // When the appointment begins
- tm _end; // When the appointment ends
diff --git a/palm/pilot-link/files/patch-ai b/palm/pilot-link/files/patch-ai
deleted file mode 100644
index 8fe6e1ef2a1..00000000000
--- a/palm/pilot-link/files/patch-ai
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/pi-iambicExpense.hxx.kan Mon Jun 17 16:34:24 2002
-+++ ./include/pi-iambicExpense.hxx Mon Jun 17 16:35:27 2002
-@@ -27,7 +27,7 @@
-
- class iambicExpense_t : public baseApp_t
- {
-- friend iambicExpenseList_t;
-+ friend class iambicExpenseList_t;
-
- short _flags;
- char *_type;
diff --git a/palm/pilot-link/files/patch-aj b/palm/pilot-link/files/patch-aj
deleted file mode 100644
index cebb77b903b..00000000000
--- a/palm/pilot-link/files/patch-aj
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/pi-memo.hxx.kan Mon Jun 17 16:34:24 2002
-+++ ./include/pi-memo.hxx Mon Jun 17 16:35:35 2002
-@@ -19,7 +19,7 @@
-
- class memo_t : public baseApp_t
- {
-- friend memoList_t;
-+ friend class memoList_t;
-
- char *_text;
- int _size;
diff --git a/palm/pilot-link/files/patch-ak b/palm/pilot-link/files/patch-ak
deleted file mode 100644
index b567ccda04d..00000000000
--- a/palm/pilot-link/files/patch-ak
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./include/pi-todo.hxx.kan Mon Jun 17 16:34:24 2002
-+++ ./include/pi-todo.hxx Mon Jun 17 16:35:43 2002
-@@ -23,7 +23,7 @@
-
- class todo_t : public baseApp_t
- {
-- friend todoList_t;
-+ friend class todoList_t;
-
- struct tm *_due; // Non-NULL if there is a due date
- int _priority; // A priority in the range 1-5
-
diff --git a/palm/pilot-link/files/patch-getopt b/palm/pilot-link/files/patch-getopt
deleted file mode 100644
index fe00280b89b..00000000000
--- a/palm/pilot-link/files/patch-getopt
+++ /dev/null
@@ -1,14 +0,0 @@
-Don' link include this useless getopt reimplementations into every
-executable. When/if pilot-link starts to use the longopt/getopt_long, it
-should check if the libc or the libgnugetopt has them first.
-
-+++ Makefile.in Fri Aug 24 10:17:57 2001
-@@ -102,1 +102,1 @@ PERLEXECS = pilot-undelete ietf2datebook
--GETOPT = getopt.o getopt1.o
-+GETOPT =
---- pilot-xfer.c Tue May 22 08:20:05 2001
-+++ pilot-xfer.c Mon Aug 27 14:44:52 2001
-@@ -33,3 +33,2 @@
- #endif
--#include "getopt.h"
- #include <sys/stat.h>
diff --git a/palm/pilot-link/files/patch-iconv b/palm/pilot-link/files/patch-iconv
deleted file mode 100644
index a74bf261bf7..00000000000
--- a/palm/pilot-link/files/patch-iconv
+++ /dev/null
@@ -1,7 +0,0 @@
-If we use iconv -- link pisock with it, so others don't have to:
-
---- libsock/Makefile.in Tue Jun 19 12:25:26 2001
-+++ libsock/Makefile.in Fri Aug 24 10:09:20 2001
-@@ -57,1 +57,1 @@
-- -o libpisock.la $(OBJS)
-+ -o libpisock.la $(OBJS) @ICONV_LIBS@