aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
Diffstat (limited to 'palm')
-rw-r--r--palm/gnome-pilot-conduits/Makefile10
-rw-r--r--palm/gnome-pilot/Makefile11
-rw-r--r--palm/gnome-pilot/pkg-plist4
-rw-r--r--palm/gnomepilot-conduits/Makefile10
-rw-r--r--palm/gnomepilot-conduits2/Makefile10
-rw-r--r--palm/gnomepilot/Makefile11
-rw-r--r--palm/gnomepilot/pkg-plist4
-rw-r--r--palm/gnomepilot2/Makefile11
-rw-r--r--palm/gnomepilot2/pkg-plist4
9 files changed, 27 insertions, 48 deletions
diff --git a/palm/gnome-pilot-conduits/Makefile b/palm/gnome-pilot-conduits/Makefile
index cf604bc06b3..ad5fb693ca1 100644
--- a/palm/gnome-pilot-conduits/Makefile
+++ b/palm/gnome-pilot-conduits/Makefile
@@ -20,17 +20,15 @@ LIB_DEPENDS= gpilotd.1:${PORTSDIR}/palm/gnomepilot
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnome-pilot/Makefile b/palm/gnome-pilot/Makefile
index f571d0ac166..573503503ee 100644
--- a/palm/gnome-pilot/Makefile
+++ b/palm/gnome-pilot/Makefile
@@ -22,7 +22,9 @@ LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs libpanel \
+ libcapplet
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
@@ -31,11 +33,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gpilot-install-file.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnome-pilot/pkg-plist b/palm/gnome-pilot/pkg-plist
index bfcec3dcf4d..21f584b2ba1 100644
--- a/palm/gnome-pilot/pkg-plist
+++ b/palm/gnome-pilot/pkg-plist
@@ -78,9 +78,5 @@ share/locale/tr/LC_MESSAGES/gnome-pilot.mo
share/locale/uk/LC_MESSAGES/gnome-pilot.mo
share/locale/zh_TW/LC_MESSAGES/gnome-pilot.mo
@dirrm share/gnome/gnome-pilot/glade
-@dirrm share/gnome/gnome-pilot/conduits
-@dirrm share/gnome/gnome-pilot
-@dirrm lib/gnome-pilot/conduits
-@dirrm lib/gnome-pilot
@dirrm include/libgpilotdCM
@dirrm include/gpilotd
diff --git a/palm/gnomepilot-conduits/Makefile b/palm/gnomepilot-conduits/Makefile
index cf604bc06b3..ad5fb693ca1 100644
--- a/palm/gnomepilot-conduits/Makefile
+++ b/palm/gnomepilot-conduits/Makefile
@@ -20,17 +20,15 @@ LIB_DEPENDS= gpilotd.1:${PORTSDIR}/palm/gnomepilot
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnomepilot-conduits2/Makefile b/palm/gnomepilot-conduits2/Makefile
index cf604bc06b3..ad5fb693ca1 100644
--- a/palm/gnomepilot-conduits2/Makefile
+++ b/palm/gnomepilot-conduits2/Makefile
@@ -20,17 +20,15 @@ LIB_DEPENDS= gpilotd.1:${PORTSDIR}/palm/gnomepilot
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnomepilot/Makefile b/palm/gnomepilot/Makefile
index f571d0ac166..573503503ee 100644
--- a/palm/gnomepilot/Makefile
+++ b/palm/gnomepilot/Makefile
@@ -22,7 +22,9 @@ LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs libpanel \
+ libcapplet
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
@@ -31,11 +33,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gpilot-install-file.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnomepilot/pkg-plist b/palm/gnomepilot/pkg-plist
index bfcec3dcf4d..21f584b2ba1 100644
--- a/palm/gnomepilot/pkg-plist
+++ b/palm/gnomepilot/pkg-plist
@@ -78,9 +78,5 @@ share/locale/tr/LC_MESSAGES/gnome-pilot.mo
share/locale/uk/LC_MESSAGES/gnome-pilot.mo
share/locale/zh_TW/LC_MESSAGES/gnome-pilot.mo
@dirrm share/gnome/gnome-pilot/glade
-@dirrm share/gnome/gnome-pilot/conduits
-@dirrm share/gnome/gnome-pilot
-@dirrm lib/gnome-pilot/conduits
-@dirrm lib/gnome-pilot
@dirrm include/libgpilotdCM
@dirrm include/gpilotd
diff --git a/palm/gnomepilot2/Makefile b/palm/gnomepilot2/Makefile
index f571d0ac166..573503503ee 100644
--- a/palm/gnomepilot2/Makefile
+++ b/palm/gnomepilot2/Makefile
@@ -22,7 +22,9 @@ LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs libpanel \
+ libcapplet
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
@@ -31,11 +33,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gpilot-install-file.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnomepilot2/pkg-plist b/palm/gnomepilot2/pkg-plist
index bfcec3dcf4d..21f584b2ba1 100644
--- a/palm/gnomepilot2/pkg-plist
+++ b/palm/gnomepilot2/pkg-plist
@@ -78,9 +78,5 @@ share/locale/tr/LC_MESSAGES/gnome-pilot.mo
share/locale/uk/LC_MESSAGES/gnome-pilot.mo
share/locale/zh_TW/LC_MESSAGES/gnome-pilot.mo
@dirrm share/gnome/gnome-pilot/glade
-@dirrm share/gnome/gnome-pilot/conduits
-@dirrm share/gnome/gnome-pilot
-@dirrm lib/gnome-pilot/conduits
-@dirrm lib/gnome-pilot
@dirrm include/libgpilotdCM
@dirrm include/gpilotd