aboutsummaryrefslogtreecommitdiffstats
path: root/polish/sms2
diff options
context:
space:
mode:
Diffstat (limited to 'polish/sms2')
-rw-r--r--polish/sms2/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/polish/sms2/Makefile b/polish/sms2/Makefile
index dd714485edd..5aec5f91707 100644
--- a/polish/sms2/Makefile
+++ b/polish/sms2/Makefile
@@ -18,11 +18,20 @@ LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
WRKSRC= ${WRKDIR}/sms
USE_GMAKE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= # empty
MAKE_ARGS= CXX="${CXX}"
.if defined(NOPORTDOCS)
MAKE_ARGS+= NOPORTDOCS=1
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/smsrc,${PREFIX}/etc/smsrc,' \
+ ${WRKSRC}/sms.h \
+ ${WRKSRC}/README.smsrc
+ @${REINPLACE_CMD} -e 's,bash,sh,' \
+ ${WRKSRC}/contrib/sms-conf
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/sms