aboutsummaryrefslogtreecommitdiffstats
path: root/print/libgnomeprint/files
diff options
context:
space:
mode:
Diffstat (limited to 'print/libgnomeprint/files')
-rw-r--r--print/libgnomeprint/files/patch-ab36
-rw-r--r--print/libgnomeprint/files/patch-configure16
-rw-r--r--print/libgnomeprint/files/patch-libgnomeprint::drivers::Makefile.in21
-rw-r--r--print/libgnomeprint/files/patch-libgnomeprint::gnome-print-meta.c15
-rw-r--r--print/libgnomeprint/files/patch-libgnomeprint::transports::Makefile.in23
5 files changed, 84 insertions, 27 deletions
diff --git a/print/libgnomeprint/files/patch-ab b/print/libgnomeprint/files/patch-ab
index f4479734a47..c20623cb30c 100644
--- a/print/libgnomeprint/files/patch-ab
+++ b/print/libgnomeprint/files/patch-ab
@@ -1,32 +1,14 @@
$FreeBSD$
---- Makefile.in.orig Fri Oct 5 11:37:00 2001
-+++ Makefile.in Fri Oct 5 11:40:45 2001
-@@ -157,7 +157,7 @@
- @LIBGPA_TRUE@LIBGPA_DIR = libgpa data
- @LIBGPA_FALSE@LIBGPA_DIR =
+--- Makefile.in.orig Mon Feb 11 12:42:17 2002
++++ Makefile.in Tue Mar 19 18:17:21 2002
+@@ -116,7 +116,7 @@
+ WARN_CFLAGS = @WARN_CFLAGS@
+ cxxflags_set = @cxxflags_set@
--SUBDIRS = intl po $(LIBGPA_DIR) libgnomeprint afms profiles fonts tests $(INSTALLER_DIR)
-+SUBDIRS = intl po $(LIBGPA_DIR) libgnomeprint afms profiles fonts $(INSTALLER_DIR)
+-SUBDIRS = libgnomeprint fonts installer tests data po
++SUBDIRS = libgnomeprint fonts installer data po
- INCLUDES = $(GTK_CFLAGS) -I$(top_srcdir)/intl -I$(top_builddir)/intl $(GNOME_INCLUDEDIR) @PRINT_INCLUDEDIR@ -DPROFILEDIR=\""$(profilesdir)"\"
-
-@@ -171,7 +171,7 @@
- EXTRA_DIST = printConf.sh.in gnome-print.spec.in gnome-print.spec run-gnome-font-install
-
-
--confexecdir = $(libdir)
-+confexecdir = $(sysconfdir)
- confexec_DATA = printConf.sh
-
- CLEANFILES = printConf.sh
-@@ -192,7 +192,7 @@
- TAR = gtar
- GZIP_ENV = --best
- DIST_SUBDIRS = intl po libgpa data libgnomeprint afms profiles fonts \
--tests installer
-+installer
- all: all-redirect
- .SUFFIXES:
- $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
+ EXTRA_DIST = message-of-doom ChangeLog ChangeLog.old ChangeLog.old.2
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/print/libgnomeprint/files/patch-configure b/print/libgnomeprint/files/patch-configure
new file mode 100644
index 00000000000..0302dcdc83f
--- /dev/null
+++ b/print/libgnomeprint/files/patch-configure
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- configure 2002/03/19 16:34:21 1.1
++++ configure 2002/03/19 16:35:22
+@@ -9926,8 +9926,8 @@
+ INSTALL_FONTS_TRUE='#'
+ INSTALL_FONTS_FALSE=
+ fi
+-FONTMAPDIR_STATIC=$datadir/gnome/libgnomeprint-2.0/fonts
+-FONTMAPDIR_DYNAMIC=$sysconfdir/gnome/libgnomeprint-2.0/fonts
++FONTMAPDIR_STATIC=$datadir/libgnomeprint-2.0/fonts
++FONTMAPDIR_DYNAMIC=$sysconfdir/gnome2/libgnomeprint-2.0/fonts
+
+ LIBGNOMEPRINT_CFLAGS="$FREETYPE_CFLAGS $CFLAGS $GLIB_CFLAGS $LIBART_CFLAGS $PANGO_CFLAGS $LIBXML_CFLAGS $LIBBONOBO_CFLAGS"
+ LIBGNOMEPRINT_LIBS="$GLIB_LIBS $LIBART_LIBS $PANGO_LIBS $LIBXML_LIBS $FREETYPE_LIBS $LIBBONOBO_LIBS"
diff --git a/print/libgnomeprint/files/patch-libgnomeprint::drivers::Makefile.in b/print/libgnomeprint/files/patch-libgnomeprint::drivers::Makefile.in
new file mode 100644
index 00000000000..10c52a895c0
--- /dev/null
+++ b/print/libgnomeprint/files/patch-libgnomeprint::drivers::Makefile.in
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- libgnomeprint/drivers/Makefile.in 2002/03/19 16:44:23 1.1
++++ libgnomeprint/drivers/Makefile.in 2002/03/19 16:48:12
+@@ -118,13 +118,13 @@
+ OMNI2_SRC = gnome-print-omni2.cpp gnome-print-omni2.hpp
+ OMNI2_LAD = -L$(OMNI_LIBDIR) -lomni
+ libgnomeprint_omni2_la_SOURCES = $(OMNI2_SRC)
+-libgnomeprint_omni2_la_LDFLAGS = -version-info 0:0:0 -module
++libgnomeprint_omni2_la_LDFLAGS = -avoid-version -module
+ libgnomeprint_omni2_la_LIBADD = $(OMNI2_LAD)
+
+ FAX_LIB = libgnomeprint-fax.la
+ FAX_SRC = gnome-print-fax.c gnome-print-fax.h gnome-print-fax-g3.h
+ libgnomeprint_fax_la_SOURCES = $(FAX_SRC)
+-libgnomeprint_fax_la_LDFLAGS = -version-info 0:0:0 -module
++libgnomeprint_fax_la_LDFLAGS = -avoid-version -module
+ libgnomeprint_fax_la_LIBADD =
+
+ libexecdir = $(libdir)/gnome-print-2.0/drivers
diff --git a/print/libgnomeprint/files/patch-libgnomeprint::gnome-print-meta.c b/print/libgnomeprint/files/patch-libgnomeprint::gnome-print-meta.c
new file mode 100644
index 00000000000..fc5f161554a
--- /dev/null
+++ b/print/libgnomeprint/files/patch-libgnomeprint::gnome-print-meta.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- libgnomeprint/gnome-print-meta.c 2002/03/19 16:19:47 1.1
++++ libgnomeprint/gnome-print-meta.c 2002/03/19 16:20:00
+@@ -28,8 +28,8 @@
+
+ #include <math.h>
+ #include <string.h>
+-#include <sys/mman.h>
+ #include <sys/types.h>
++#include <sys/mman.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <fcntl.h>
diff --git a/print/libgnomeprint/files/patch-libgnomeprint::transports::Makefile.in b/print/libgnomeprint/files/patch-libgnomeprint::transports::Makefile.in
new file mode 100644
index 00000000000..9ced5d89bd2
--- /dev/null
+++ b/print/libgnomeprint/files/patch-libgnomeprint::transports::Makefile.in
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- libgnomeprint/transports/Makefile.in 2002/03/19 16:46:00 1.1
++++ libgnomeprint/transports/Makefile.in 2002/03/19 16:48:02
+@@ -131,7 +131,7 @@
+
+ libgnomeprint_file_la_SOURCES = $(FILE_SRC)
+
+-libgnomeprint_file_la_LDFLAGS = -version-info 0:0:0 -module
++libgnomeprint_file_la_LDFLAGS = -avoid-version -module
+
+ libgnomeprint_file_la_LIBADD =
+
+@@ -142,7 +142,7 @@
+
+ libgnomeprint_lpr_la_SOURCES = $(LPR_SRC)
+
+-libgnomeprint_lpr_la_LDFLAGS = -version-info 0:0:0 -module
++libgnomeprint_lpr_la_LDFLAGS = -avoid-version -module
+
+ libgnomeprint_lpr_la_LIBADD =
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs