aboutsummaryrefslogtreecommitdiffstats
path: root/print/lilypond/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/lilypond/Makefile')
-rw-r--r--print/lilypond/Makefile56
1 files changed, 12 insertions, 44 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 0fbaf5ee544..63436c9d72a 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -8,16 +8,9 @@
#
PORTNAME= lilypond
-PORTVERSION= 2.13.54
+PORTVERSION= 2.13.55
CATEGORIES= print audio
-MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v2.13/:src \
- ${MASTER_SITE_LOCAL}/gahr/:fonts \
- http://people.freebsd.org/~gahr/distfiles/:fonts \
- http://www.chiark.greenend.org.uk/~sgtatham/gonville/:gonville
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:src \
- ${PORTNAME}-fonts-${PORTVERSION}${EXTRACT_SUFX}:fonts \
- gonville-${GONVILLE_REV}${EXTRACT_SUFX}:gonville
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v2.13/
MAINTAINER= gahr@FreeBSD.org
COMMENT= The GNU music typesetter
@@ -28,16 +21,13 @@ BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX \
texi2html:${PORTSDIR}/textproc/texi2html \
pdftexi2dvi:${PORTSDIR}/print/texinfo \
zip:${PORTSDIR}/archivers/zip \
- gsed:${PORTSDIR}/textproc/gsed
+ gsed:${PORTSDIR}/textproc/gsed \
+ ${LOCALBASE}/share/ghostscript/fonts/c059033l.pfb:${PORTSDIR}/print/gsfonts
LIB_DEPENDS= guile.20:${PORTSDIR}/lang/guile \
gmp.10:${PORTSDIR}/math/gmp
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
- mftrace:${PORTSDIR}/print/mftrace
-
-GONVILLE_REV= r8724
-GONVILLE_SIZES= 11 13 14 16 18 20 23 26
-
-#OPTIONS= WEBDOCS "Include web documentation" off
+ mftrace:${PORTSDIR}/print/mftrace \
+ ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf:${PORTSDIR}/x11-fonts/dejavu
MAN1= lilymidi.1 lilypond-book.1 lilypond-invoke-editor.1 \
lilypond.1 lilysong.1 convert-ly.1 abc2ly.1 etf2ly.1 \
@@ -47,46 +37,29 @@ INFO= lilypond-changes lilypond-contributor lilypond-essay \
lilypond-notation lilypond-usage lilypond-web \
music-glossary
-USE_AUTOTOOLS= autoconf
USE_BISON= build
USE_GETTEXT= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_GNOME= pango
-INSTALLS_OMF= yes
MAKEFILE= GNUmakefile
-ALL_TARGET= all
+GNU_MAKEFILE= yes
+CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts
CONFIGURE_ENV+= MAKEINFO="${LOCALBASE}/bin/makeinfo"
+
+ALL_TARGET= all
+
NOCCACHE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if !defined(NOPORTDOCS) && defined(WITH_WEBDOCS)
-IGNORE= installation of webdocs does not work
-BUILD_DEPENDS+= pbmpscale:${PORTSDIR}/graphics/netpbm \
- rsync:${PORTSDIR}/net/rsync
-PLIST_SUB+= DOCS=""
-PORTDOCS+= *
-.else
-PLIST_SUB+= DOCS="@comment "
-.endif
-
-post-extract:
- ${TAR} -C ${WRKDIR} -xf ${DISTDIR}/${PORTNAME}-fonts-${PORTVERSION}${EXTRACT_SUFX}
- ${TAR} -C ${WRKDIR} -xf ${DISTDIR}/gonville-${GONVILLE_REV}${EXTRACT_SUFX} && \
- ${CP} ${WRKDIR}/gonville-${GONVILLE_REV}/lilyfonts/otf/* ${WRKSRC}/mf/out/
-.for size in ${GONVILLE_SIZES}
- ${LN} -s ${WRKSRC}/mf/out/gonville${size}.otf ${WRKSRC}/mf/out/gonville-${size}.otf
-.endfor
-
post-patch:
- ${REINPLACE_CMD} -e 's|makeinfo|${LOCALBASE}/bin/makeinfo|' \
+ ${REINPLACE_CMD} -e 's|makeinfo|${LOCALBASE}/bin/makeinfo|; s|find -maxdepth|find . -maxdepth|g' \
${WRKSRC}/configure
${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
${WRKSRC}/lily/include/includable-lexer.hh
- ${REINPLACE_CMD} -e 's|sed|gsed|g' ${WRKSRC}/Documentation/GNUmakefile
.if defined(WITHOUT_NLS)
${REINPLACE_CMD} -e '17,21d' ${WRKSRC}/po/GNUmakefile
.endif
@@ -98,10 +71,5 @@ pre-install:
post-install:
@${LN} -s ${DATADIR}/${PORTVERSION} ${DATADIR}/current
-.if !defined(NOPORTDOCS) && defined(WITH_WEBDOCS)
- @echo "Installing documentation... this takes a while..."
- cd ${WRKSRC} && ${GMAKE} doc install-doc
-# @(cd ${WRKSRC}/out-www/offline-root && ${COPYTREE_SHARE} \* ${DOCSDIR})
-.endif
.include <bsd.port.post.mk>