aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdftk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/pdftk/Makefile')
-rw-r--r--print/pdftk/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index a898901c193..18020811d89 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -2,29 +2,31 @@
# $FreeBSD$
PORTNAME= pdftk
-PORTVERSION= 1.45
-PORTREVISION= 1
+PORTVERSION= 2.02
CATEGORIES= print
-MASTER_SITES= http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/ \
- LOCAL/glarkin
+MASTER_SITES= http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Simple tool for doing everyday things with PDF documents
-USE_ZIP= yes
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgcj.so:${PORTSDIR}/lang/gcc${CSUFF} \
+ libstdc++.so:${PORTSDIR}/lang/gcc${CSUFF} \
+ libgcc_s.so:${PORTSDIR}/lang/gcc${CSUFF}
BUILD_DEPENDS= gcj${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF} \
gcjh${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF} \
cpp${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF}
+USE_ZIP= yes
+
# Get GCC version suffix without the dot in USE_GCC
CSUFF= ${_USE_GCC:S/.//}
USE_GCC= yes
-USE_GMAKE= yes
-USES= iconv
-USE_LDCONFIG= ${PREFIX}/lib/gcc${CSUFF}
+USES= iconv gmake
# gcj/libgcj don't exist on some platforms
ONLY_FOR_ARCHS= i386 amd64
@@ -42,15 +44,6 @@ PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
post-patch:
@${REINPLACE_CMD} -e "s|TOOLPATH=|TOOLPATH=${LOCALBASE}/bin/|g" ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s|VERSUFF=|VERSUFF=${CSUFF}|g" ${WRKSRC}/${MAKEFILE}
-
-#2005-10-29 - mjoyner@vbservices.net/mjoyner@ewc.edu
-#as shipped, pdftk compiles fine with 3.4 gcj, as we currently only have 4.1 gcj available,
-#fix things so that it will compile. (compile tested on 5.4-STABLE)
-#
-#The resulting binary from using the 4.1 compiler suite has *NOT* been regression tested!
-#Based on info found via Google USENET Search: Adam McDougall, Gerald Pfeifer
-#
-
@${REINPLACE_CMD} -e "s|GCJFLAGS=|GCJFLAGS= -L${LOCALBASE}/lib -Wl,-rpath=${LOCALBASE}/lib/gcc${CSUFF} -w|g" ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s|LDLIBS= -lgcj|LDLIBS= -lgcj ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} ${ICONV_LIB} -lz -L${LOCALBASE}/lib -Wl,-rpath=${LOCALBASE}/lib/gcc${CSUFF} -w|g" \
${WRKSRC}/${MAKEFILE}