aboutsummaryrefslogtreecommitdiffstats
path: root/russian/xneur/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'russian/xneur/Makefile')
-rw-r--r--russian/xneur/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/russian/xneur/Makefile b/russian/xneur/Makefile
index 814e893d766..708a42043d6 100644
--- a/russian/xneur/Makefile
+++ b/russian/xneur/Makefile
@@ -6,31 +6,36 @@
#
PORTNAME= xneur
-PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTVERSION= 0.9.2
CATEGORIES= russian
MASTER_SITES= http://dists.xneur.ru/release-${DISTVERSION}/tgz/ CENKES
MAINTAINER= admin@lissyara.su
COMMENT= Auto keyboard switcher
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ aspell:${PORTSDIR}/textproc/aspell
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --libdir=${PREFIX}/lib/xneur
USE_BZIP2= yes
-USE_XORG= x11
+USE_XORG= x11 xpm
+USE_GCC= 4.2+
USE_LDCONFIG= yes
+USE_GSTREAMER= yes
MAKE_ARGS= pkgconfigdir=${PREFIX}/libdata/pkgconfig
+#DATADIR= ${SHAREDIR}/${PORTNAME}
+MAN1= xneur.1
+MAN5= xneurrc.5
post-patch:
@${REINPLACE_CMD} -e '/^CFLAGS=/s|="|="$$CFLAGS |' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^am__strip_dir/s#`;#|sed -Ee \
- "s/^(dict.dist|proto|proto3|langdef|regexp|xneurrc|xneurrc-be|xneurrc-uk|xneurrc-fr|xneurrc-ro|dict)$$$$/\\1.dist/"`;#' \
- ${WRKSRC}/etc/Makefile.in ${WRKSRC}/etc/*/Makefile.in
+ "s/^(dict.dist|proto|proto3|langdef|regexp|xneurrc|xneurrc-be|xneurrc-uk|xneurrc-fr|xneurrc-ro|xneurrc-de|xneurrc-kz|dict)$$$$/\\1.dist/"`;#' \
+ ${WRKSRC}/etc/Makefile.in ${WRKSRC}/etc/Makefile.am
post-install:
- @for i in ${PREFIX}/etc/xneur/*.dist ${PREFIX}/etc/xneur/*/*.dist;\
+ @for i in ${PREFIX}/etc/xneur/*.dist ;\
do ${CP} -np $$i $${i%.dist}; done
.include <bsd.port.pre.mk>