aboutsummaryrefslogtreecommitdiffstats
path: root/science/mpqc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/mpqc/Makefile')
-rw-r--r--science/mpqc/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 6929448be3e..fd4a122a1ff 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= science parallel
MASTER_SITES= SF
@@ -16,12 +16,11 @@ GNU_CONFIGURE= yes
USES= fortran gmake libtool perl5 tar:bzip2
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
-MPQC_COMMAND= ${PREFIX}/bin/mpqc
CONFIGURE_ARGS+=--with-cc=${CC} \
--with-cxx=${CXX} \
--with-f77=${FC} \
- --with-include="-I${WRKDIR} -I${LOCALBASE}/include" \
+ --with-include="-I${LOCALBASE}/include" \
--with-libdirs="-L${LOCALBASE}/lib ${LDFLAGS}" \
--with-blas="${BLAS}" \
--with-lapack="${LAPACK}" \
@@ -84,6 +83,11 @@ CFLAGS+= -O2 -ffast-math
CXXFLAGS+= -O2 -ffast-math
.endif
+post-patch:
+ # To get so.8.0.1, we need to -version-info to show 8.1.0
+ # <current>:<rev>:<age> => so.(current-age).(age).(rev)
+ ${REINPLACE_CMD} -e 's|\[8:0:1\]|\[8:1:0\]|' ${WRKSRC}/configure.in
+
do-build:
(cd ${WRKSRC} && ${MAKE_CMD})
.if ${PORT_OPTIONS:MDOCS}