aboutsummaryrefslogtreecommitdiffstats
path: root/security/drweb-sendmail/files/Makefile.libmilter
diff options
context:
space:
mode:
Diffstat (limited to 'security/drweb-sendmail/files/Makefile.libmilter')
-rw-r--r--security/drweb-sendmail/files/Makefile.libmilter20
1 files changed, 20 insertions, 0 deletions
diff --git a/security/drweb-sendmail/files/Makefile.libmilter b/security/drweb-sendmail/files/Makefile.libmilter
new file mode 100644
index 00000000000..b891e9bc2b9
--- /dev/null
+++ b/security/drweb-sendmail/files/Makefile.libmilter
@@ -0,0 +1,20 @@
+# $FreeBSD$
+#
+SENDMAIL_DIR=/usr/src/contrib/sendmail
+.PATH: ${SENDMAIL_DIR}/libmilter
+
+CFLAGS+=-I${SENDMAIL_DIR}/src -I${SENDMAIL_DIR}/include
+CFLAGS+=-DNEWDB -DNIS -DMAP_REGEX -DNOT_SENDMAIL -D_FFR_MILTER=1
+
+# User customizations to the sendmail build environment
+CFLAGS+=${SENDMAIL_CFLAGS}
+
+LIB= milter
+
+SRCS+= comm.c engine.c handler.c listener.c main.c signal.c sm_gethost.c smfi.c
+
+INTERNALLIB= true
+NOPIC= true
+INTERNALSTATICLIB= true
+
+.include <bsd.lib.mk>