aboutsummaryrefslogtreecommitdiffstats
path: root/security/kwallet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/kwallet/Makefile')
-rw-r--r--security/kwallet/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index 6667a23a332..a2cdd777537 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>