aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl-beta/Makefile.ssl
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl-beta/Makefile.ssl')
-rw-r--r--security/openssl-beta/Makefile.ssl56
1 files changed, 0 insertions, 56 deletions
diff --git a/security/openssl-beta/Makefile.ssl b/security/openssl-beta/Makefile.ssl
deleted file mode 100644
index 316b1213a6f..00000000000
--- a/security/openssl-beta/Makefile.ssl
+++ /dev/null
@@ -1,56 +0,0 @@
-# makefile for use of: OpenSSH
-# Date created: 31 May 2002
-# Whom: dinoex
-#
-# $FreeBSD$
-#
-
-.if defined(USE_OPENSSL_BASE)
-OPENSSLBASE= /usr
-OPENSSLDIR= /etc/ssl
-
-.if !exists(/usr/lib/libcrypto.so)
-.BEGIN:
- @${ECHO_CMD} "This port requires the OpenSSL library, which is part of"
- @${ECHO_CMD} "the FreeBSD crypto distribution but not installed on your"
- @${ECHO_CMD} "machine. Please see the \"OpenSSL\" section in the handbook"
- @${ECHO_CMD} "(at \"http://www.FreeBSD.org/doc/en_US.ISO8859-1/books/handbook/openssl.html\", for instance)"
- @${ECHO_CMD} "for instructions on how to obtain and install the FreeBSD"
- @${ECHO_CMD} "OpenSSL distribution."
- @${FALSE}
-.endif
-
-# OpenSSL in the base system may not include IDEA for patent licensing reasons.
-.if defined(MAKE_IDEA) && !defined(OPENSSL_IDEA)
-OPENSSL_IDEA= ${MAKE_IDEA}
-.else
-OPENSSL_IDEA?= NO
-.endif
-
-.if ${OPENSSL_IDEA} == "NO"
-# XXX This is a hack to work around the fact that /etc/make.conf clobbers
-# our CFLAGS. It might not be enough for all future ports.
-.if defined(HAS_CONFIGURE)
-CFLAGS+= -DNO_IDEA
-.else
-OPENSSL_CFLAGS+= -DNO_IDEA
-.endif
-MAKE_ARGS+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}"
-.endif
-
-.else
-
-OPENSSLBASE= ${LOCALBASE}
-OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
-
-.endif
-
-OPENSSLLIB= ${OPENSSLBASE}/lib
-OPENSSLINC= ${OPENSSLBASE}/include
-MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
- OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
-
-### crypto
-#RESTRICTED= "Contains cryptography."
-