aboutsummaryrefslogtreecommitdiffstats
path: root/security/pond
diff options
context:
space:
mode:
Diffstat (limited to 'security/pond')
-rw-r--r--security/pond/Makefile54
-rw-r--r--security/pond/distinfo12
2 files changed, 41 insertions, 25 deletions
diff --git a/security/pond/Makefile b/security/pond/Makefile
index 5ea0d5f6879..be0c82da8c3 100644
--- a/security/pond/Makefile
+++ b/security/pond/Makefile
@@ -1,13 +1,12 @@
# $FreeBSD$
PORTNAME= pond
-PORTVERSION= 20140824
-PORTREVISION= 2
+PORTVERSION= 20150830
CATEGORIES= security
MASTER_SITES= http://c-s.li/ports/
-DISTFILES= pond-20140824.tar.gz \
- go-gtk-20140629.tar.gz \
- ed25519-20140215.tar.gz
+DISTFILES= pond-20150830.tar.gz \
+ go-gtk-20151214.tar.gz \
+ ed25519-20150830.tar.gz
MAINTAINER= cs@FreeBSD.org
COMMENT= Forward secure, asynchronous messenger
@@ -32,28 +31,45 @@ post-extract:
@${LN} -sf ${WRKSRC} ${GO_WRKSRC}
@${LN} -sf ${WRKSRC}/client ${WRKSRC}/pond
@${LN} -sf ${WRKSRC}/server ${WRKSRC}/pond-server
- @${LN} -sf ${WRKDIR}/go-gtk-20140629 ${GO_WRKDIR_SRC}/github.com/agl/go-gtk
- @${LN} -sf ${WRKDIR}/ed25519-20140215 ${GO_WRKDIR_SRC}/github.com/agl/ed25519
+ @${LN} -sf ${WRKDIR}/go-gtk-20151214 ${GO_WRKDIR_SRC}/github.com/agl/go-gtk
+ @${LN} -sf ${WRKDIR}/ed25519-20150830 ${GO_WRKDIR_SRC}/github.com/agl/ed25519
post-patch:
@${REINPLACE_CMD} -e 's|\<gdk|\<gtk-3.0\/gdk|g' \
- ${WRKDIR}/go-gtk-20140629/gdk/gdk.go \
- ${WRKDIR}/go-gtk-20140629/gdk/gdk_linux.go \
- ${WRKDIR}/go-gtk-20140629/gdk/gdk_windows.go \
- ${WRKDIR}/go-gtk-20140629/gtk/gtk.go
+ ${WRKDIR}/go-gtk-20151214/gdk/gdk.go \
+ ${WRKDIR}/go-gtk-20151214/gdk/gdk_linux.go \
+ ${WRKDIR}/go-gtk-20151214/gdk/gdk_windows.go \
+ ${WRKDIR}/go-gtk-20151214/gtk/gtk.go
@${REINPLACE_CMD} -e 's|\<pango|\<pango-1.0\/pango|g' \
- ${WRKDIR}/go-gtk-20140629/pango/pango.go
+ ${WRKDIR}/go-gtk-20151214/pango/pango.go
@${REINPLACE_CMD} -e 's|\<gtk|\<gtk-3.0\/gtk|g' \
- ${WRKDIR}/go-gtk-20140629/gtk/gtk.go \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_fedora.go \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_ubuntu.go
+ ${WRKDIR}/go-gtk-20151214/gtk/gtk.go \
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_fedora.go \
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_ubuntu.go
@${REINPLACE_CMD} -e 's|\<glib|\<glib-2.0\/glib|g' \
- ${WRKDIR}/go-gtk-20140629/glib/glib.go
+ ${WRKDIR}/go-gtk-20151214/glib/glib.go
@${REINPLACE_CMD} -e 's|\<gdk-pixbuf|\<gdk-pixbuf-2.0\/gdk-pixbuf|g' \
- ${WRKDIR}/go-gtk-20140629/gdkpixbuf/gdkpixbuf.go
+ ${WRKDIR}/go-gtk-20151214/gdkpixbuf/gdkpixbuf.go
@${REINPLACE_CMD} -e 's|\<gtkspell|\<gtkspell-2.0\/gtkspell|g' \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_fedora.go \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_ubuntu.go
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_fedora.go \
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_ubuntu.go
+ @${REINPLACE_CMD} -e 's|golang.org\/x\/crypto|code.google.com\/p\/go.crypto|g' \
+ ${WRKDIR}/pond-20150830/bbssig/bbssig.go \
+ ${WRKDIR}/pond-20150830/transport/transport.go \
+ ${WRKDIR}/pond-20150830/pond-server/main.go \
+ ${WRKDIR}/pond-20150830/protos/const.go \
+ ${WRKDIR}/pond-20150830/client/ratchet/ratchet.go \
+ ${WRKDIR}/pond-20150830/panda/panda.go \
+ ${WRKDIR}/pond-20150830/pond/client.go \
+ ${WRKDIR}/pond-20150830/pond/disk.go \
+ ${WRKDIR}/pond-20150830/pond/network.go \
+ ${WRKDIR}/pond-20150830/client/disk/disk.go \
+ ${WRKDIR}/pond-20150830/pond/background.go \
+ ${WRKDIR}/pond-20150830/pond/cli-input.go \
+ ${WRKDIR}/pond-20150830/pond/cli.go
+ @${REINPLACE_CMD} -e 's|golang.org/x/net|code.google.com\/p\/go.net|g' \
+ ${WRKDIR}/pond-20150830/panda/appengine.go \
+ ${WRKDIR}/pond-20150830/pond/network.go
do-build:
@(cd ${GO_WRKSRC}; ${SETENV} ${GO_ENV} ${GO_CMD} install -tags nogui -v ${GO_TARGET})
diff --git a/security/pond/distinfo b/security/pond/distinfo
index 6b476594b58..246db9cd959 100644
--- a/security/pond/distinfo
+++ b/security/pond/distinfo
@@ -1,6 +1,6 @@
-SHA256 (pond-20140824.tar.gz) = a75a442ba36ed2baee23768cef2412355d6d96b7cdf08e3c65bb991e4147a02c
-SIZE (pond-20140824.tar.gz) = 1056699
-SHA256 (go-gtk-20140629.tar.gz) = 9ae95725a7ea0d7b0397447f36dc7f274ce17be67a7e28104bd6e08aa67143ed
-SIZE (go-gtk-20140629.tar.gz) = 206490
-SHA256 (ed25519-20140215.tar.gz) = e65f38ba055a8ce92764486a2b5b2a390793ed61c5c5b00f4e56ce88a9c03f9c
-SIZE (ed25519-20140215.tar.gz) = 105713
+SHA256 (pond-20150830.tar.gz) = a9c1ccaeb3d491e117ffa47a524a6ca5199907ad05f2f253358169396057a71c
+SIZE (pond-20150830.tar.gz) = 1092039
+SHA256 (go-gtk-20151214.tar.gz) = f7120523b69f52e9e3a3c9b6adf0e540e27243f2218537d44dacfe630681b536
+SIZE (go-gtk-20151214.tar.gz) = 206581
+SHA256 (ed25519-20150830.tar.gz) = f5650363a6b0c6d47a9217b72e4a70d28ab692ef73faee3a24ffd3cec7488fa7
+SIZE (ed25519-20150830.tar.gz) = 105969