aboutsummaryrefslogtreecommitdiffstats
path: root/security/sshit
diff options
context:
space:
mode:
Diffstat (limited to 'security/sshit')
-rw-r--r--security/sshit/Makefile1
-rw-r--r--security/sshit/files/patch-sshit.diff11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/sshit/Makefile b/security/sshit/Makefile
index a06263f3a04..7616c0b65b6 100644
--- a/security/sshit/Makefile
+++ b/security/sshit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sshit
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://anp.ath.cx/sshit/ \
${MASTER_SITE_LOCAL}
diff --git a/security/sshit/files/patch-sshit.diff b/security/sshit/files/patch-sshit.diff
new file mode 100644
index 00000000000..9cdce15bccd
--- /dev/null
+++ b/security/sshit/files/patch-sshit.diff
@@ -0,0 +1,11 @@
+--- sshit.orig Sun Jul 1 22:13:45 2007
++++ sshit Sun Jul 1 22:14:46 2007
+@@ -317,7 +317,7 @@
+
+ while (<>) {
+ chomp;
+- if (/(failed|Invalid user) .*from (\d+\.\d+\.\d+\.\d+|[\da-fA-F:]+)/i ) { # IPv4 & IPv6
++ if (/(failed|error|Invalid user) .*from (\d+\.\d+\.\d+\.\d+|[\da-fA-F:]+)/i ) { # IPv4 & IPv6
+ $ip = $2;
+ if ($list{$ip}{name}) {
+ if ($list{$ip}{n} >= $MAX_COUNT) {