aboutsummaryrefslogtreecommitdiffstats
path: root/security/yersinia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/yersinia/Makefile')
-rw-r--r--security/yersinia/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
new file mode 100644
index 00000000000..0b218834279
--- /dev/null
+++ b/security/yersinia/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: yersinia
+# Date created: Sun Jul 24 10:43:13 CEST 2005
+# Whom: se
+#
+# $FreeBSD$
+#
+
+PORTNAME= yersinia
+PORTVERSION= 0.5.4
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
+
+# Dependency on file that is not also installed by libnet (1.0.2) port!
+BUILD_DEPENDS= ${LOCALBASE}/share/examples/libnet/ip_raw.c:${PORTSDIR}/net/libnet-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN8= yersinia.8
+CFLAGS+= -DNEED_GETOPT_H
+PLIST_FILES= sbin/yersinia
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/yersinia ${PREFIX}/sbin/
+ ${INSTALL_MAN} ${WRKSRC}/yersinia.8 ${PREFIX}/man/man8/
+
+.include <bsd.port.mk>