aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/cfs/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/cfs/Makefile b/security/cfs/Makefile
index ce733aaf5b2..92c20784c74 100644
--- a/security/cfs/Makefile
+++ b/security/cfs/Makefile
@@ -24,6 +24,12 @@ SUB_FILES= pkg-message
SUB_LIST= CFSD_BOOTSTRAP=${CFSD_BOOTSTRAP}
PLIST_SUB= CFSD_BOOTSTRAP=${CFSD_BOOTSTRAP}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on FreeBSD 6.x
+.endif
+
post-patch:
${REINPLACE_CMD} 's/^\.TH SSH/.TH CFSSH/' ${WRKSRC}/cfssh.1
@@ -39,4 +45,4 @@ do-install:
${INSTALL} -d ${_BINOWNGRP} -m 0 ${CFSD_BOOTSTRAP}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>