aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/gnome-keyring/Makefile9
-rw-r--r--security/gnome-keyring/distinfo4
-rw-r--r--security/gnome-keyring/files/patch-gnome-keyring-daemon.c34
-rw-r--r--security/gnome-keyring/files/patch-gnome-keyring-daemon.c.orig0
-rw-r--r--security/gnome-keyring/pkg-plist8
-rw-r--r--security/gnomekeyring/Makefile9
-rw-r--r--security/gnomekeyring/distinfo4
-rw-r--r--security/gnomekeyring/files/patch-gnome-keyring-daemon.c34
-rw-r--r--security/gnomekeyring/files/patch-gnome-keyring-daemon.c.orig0
-rw-r--r--security/gnomekeyring/pkg-plist8
10 files changed, 96 insertions, 14 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index b387e2e027b..697617e18a5 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomekeyring
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-keyring/0.2
+MASTER_SITE_SUBDIR= sources/gnome-keyring/0.4
DISTNAME= gnome-keyring-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,9 +18,9 @@ COMMENT= A program that keeps passwords and other secrets
USE_X_PREFIX= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack lthack gtk20
+USE_GNOME= gnomehack gtk20
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
index 281cbb93867..f3fb17b6455 100644
--- a/security/gnome-keyring/distinfo
+++ b/security/gnome-keyring/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-keyring-0.2.1.tar.bz2) = 2fe5fb39cc18d1a6792fd3281223dfff
-SIZE (gnome2/gnome-keyring-0.2.1.tar.bz2) = 324989
+MD5 (gnome2/gnome-keyring-0.4.0.tar.bz2) = 683b422b77c56c3a125e7aa5c886c47e
+SIZE (gnome2/gnome-keyring-0.4.0.tar.bz2) = 344937
diff --git a/security/gnome-keyring/files/patch-gnome-keyring-daemon.c b/security/gnome-keyring/files/patch-gnome-keyring-daemon.c
new file mode 100644
index 00000000000..293df59b976
--- /dev/null
+++ b/security/gnome-keyring/files/patch-gnome-keyring-daemon.c
@@ -0,0 +1,34 @@
+--- gnome-keyring-daemon.c.orig Tue Jul 20 22:41:27 2004
++++ gnome-keyring-daemon.c Tue Jul 20 22:43:03 2004
+@@ -121,7 +121,7 @@
+ int i;
+
+ got_random = FALSE;
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+ {
+ int fd;
+
+@@ -352,6 +352,22 @@
+ app_ref->pathname[len] = 0;
+ }
+
++ }
++#elif defined(__FreeBSD__)
++ {
++ char buffer[1024];
++ int len;
++ char *path;
++
++ path = g_strdup_printf ("/proc/%d/file", pid);
++ len = readlink (path, buffer, sizeof (buffer));
++ g_free (path);
++
++ if (len > 0) {
++ app_ref->pathname = g_malloc (len + 1);
++ memcpy (app_ref->pathname, buffer, len);
++ app_ref->pathname[len] = 0;
++ }
+ }
+ #endif
+
diff --git a/security/gnome-keyring/files/patch-gnome-keyring-daemon.c.orig b/security/gnome-keyring/files/patch-gnome-keyring-daemon.c.orig
new file mode 100644
index 00000000000..e69de29bb2d
--- /dev/null
+++ b/security/gnome-keyring/files/patch-gnome-keyring-daemon.c.orig
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
index e8992e17d0e..f28f54a16ab 100644
--- a/security/gnome-keyring/pkg-plist
+++ b/security/gnome-keyring/pkg-plist
@@ -7,6 +7,9 @@ libdata/pkgconfig/gnome-keyring-1.pc
libexec/gnome-keyring-ask
share/locale/ar/LC_MESSAGES/gnome-keyring.mo
share/locale/az/LC_MESSAGES/gnome-keyring.mo
+share/locale/bg/LC_MESSAGES/gnome-keyring.mo
+share/locale/bn/LC_MESSAGES/gnome-keyring.mo
+share/locale/bs/LC_MESSAGES/gnome-keyring.mo
share/locale/ca/LC_MESSAGES/gnome-keyring.mo
share/locale/cs/LC_MESSAGES/gnome-keyring.mo
share/locale/cy/LC_MESSAGES/gnome-keyring.mo
@@ -16,10 +19,12 @@ share/locale/el/LC_MESSAGES/gnome-keyring.mo
share/locale/en_CA/LC_MESSAGES/gnome-keyring.mo
share/locale/en_GB/LC_MESSAGES/gnome-keyring.mo
share/locale/es/LC_MESSAGES/gnome-keyring.mo
+share/locale/eu/LC_MESSAGES/gnome-keyring.mo
share/locale/fi/LC_MESSAGES/gnome-keyring.mo
share/locale/fr/LC_MESSAGES/gnome-keyring.mo
share/locale/hr/LC_MESSAGES/gnome-keyring.mo
share/locale/hu/LC_MESSAGES/gnome-keyring.mo
+share/locale/id/LC_MESSAGES/gnome-keyring.mo
share/locale/is/LC_MESSAGES/gnome-keyring.mo
share/locale/it/LC_MESSAGES/gnome-keyring.mo
share/locale/ja/LC_MESSAGES/gnome-keyring.mo
@@ -27,18 +32,21 @@ share/locale/ko/LC_MESSAGES/gnome-keyring.mo
share/locale/lt/LC_MESSAGES/gnome-keyring.mo
share/locale/mn/LC_MESSAGES/gnome-keyring.mo
share/locale/ms/LC_MESSAGES/gnome-keyring.mo
+share/locale/nb/LC_MESSAGES/gnome-keyring.mo
share/locale/nl/LC_MESSAGES/gnome-keyring.mo
share/locale/no/LC_MESSAGES/gnome-keyring.mo
share/locale/pa/LC_MESSAGES/gnome-keyring.mo
share/locale/pl/LC_MESSAGES/gnome-keyring.mo
share/locale/pt/LC_MESSAGES/gnome-keyring.mo
share/locale/pt_BR/LC_MESSAGES/gnome-keyring.mo
+share/locale/ro/LC_MESSAGES/gnome-keyring.mo
share/locale/ru/LC_MESSAGES/gnome-keyring.mo
share/locale/sk/LC_MESSAGES/gnome-keyring.mo
share/locale/sq/LC_MESSAGES/gnome-keyring.mo
share/locale/sr/LC_MESSAGES/gnome-keyring.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-keyring.mo
share/locale/sv/LC_MESSAGES/gnome-keyring.mo
+share/locale/ta/LC_MESSAGES/gnome-keyring.mo
share/locale/th/LC_MESSAGES/gnome-keyring.mo
share/locale/tr/LC_MESSAGES/gnome-keyring.mo
share/locale/uk/LC_MESSAGES/gnome-keyring.mo
diff --git a/security/gnomekeyring/Makefile b/security/gnomekeyring/Makefile
index b387e2e027b..697617e18a5 100644
--- a/security/gnomekeyring/Makefile
+++ b/security/gnomekeyring/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomekeyring
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-keyring/0.2
+MASTER_SITE_SUBDIR= sources/gnome-keyring/0.4
DISTNAME= gnome-keyring-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,9 +18,9 @@ COMMENT= A program that keeps passwords and other secrets
USE_X_PREFIX= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack lthack gtk20
+USE_GNOME= gnomehack gtk20
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/security/gnomekeyring/distinfo b/security/gnomekeyring/distinfo
index 281cbb93867..f3fb17b6455 100644
--- a/security/gnomekeyring/distinfo
+++ b/security/gnomekeyring/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-keyring-0.2.1.tar.bz2) = 2fe5fb39cc18d1a6792fd3281223dfff
-SIZE (gnome2/gnome-keyring-0.2.1.tar.bz2) = 324989
+MD5 (gnome2/gnome-keyring-0.4.0.tar.bz2) = 683b422b77c56c3a125e7aa5c886c47e
+SIZE (gnome2/gnome-keyring-0.4.0.tar.bz2) = 344937
diff --git a/security/gnomekeyring/files/patch-gnome-keyring-daemon.c b/security/gnomekeyring/files/patch-gnome-keyring-daemon.c
new file mode 100644
index 00000000000..293df59b976
--- /dev/null
+++ b/security/gnomekeyring/files/patch-gnome-keyring-daemon.c
@@ -0,0 +1,34 @@
+--- gnome-keyring-daemon.c.orig Tue Jul 20 22:41:27 2004
++++ gnome-keyring-daemon.c Tue Jul 20 22:43:03 2004
+@@ -121,7 +121,7 @@
+ int i;
+
+ got_random = FALSE;
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+ {
+ int fd;
+
+@@ -352,6 +352,22 @@
+ app_ref->pathname[len] = 0;
+ }
+
++ }
++#elif defined(__FreeBSD__)
++ {
++ char buffer[1024];
++ int len;
++ char *path;
++
++ path = g_strdup_printf ("/proc/%d/file", pid);
++ len = readlink (path, buffer, sizeof (buffer));
++ g_free (path);
++
++ if (len > 0) {
++ app_ref->pathname = g_malloc (len + 1);
++ memcpy (app_ref->pathname, buffer, len);
++ app_ref->pathname[len] = 0;
++ }
+ }
+ #endif
+
diff --git a/security/gnomekeyring/files/patch-gnome-keyring-daemon.c.orig b/security/gnomekeyring/files/patch-gnome-keyring-daemon.c.orig
new file mode 100644
index 00000000000..e69de29bb2d
--- /dev/null
+++ b/security/gnomekeyring/files/patch-gnome-keyring-daemon.c.orig
diff --git a/security/gnomekeyring/pkg-plist b/security/gnomekeyring/pkg-plist
index e8992e17d0e..f28f54a16ab 100644
--- a/security/gnomekeyring/pkg-plist
+++ b/security/gnomekeyring/pkg-plist
@@ -7,6 +7,9 @@ libdata/pkgconfig/gnome-keyring-1.pc
libexec/gnome-keyring-ask
share/locale/ar/LC_MESSAGES/gnome-keyring.mo
share/locale/az/LC_MESSAGES/gnome-keyring.mo
+share/locale/bg/LC_MESSAGES/gnome-keyring.mo
+share/locale/bn/LC_MESSAGES/gnome-keyring.mo
+share/locale/bs/LC_MESSAGES/gnome-keyring.mo
share/locale/ca/LC_MESSAGES/gnome-keyring.mo
share/locale/cs/LC_MESSAGES/gnome-keyring.mo
share/locale/cy/LC_MESSAGES/gnome-keyring.mo
@@ -16,10 +19,12 @@ share/locale/el/LC_MESSAGES/gnome-keyring.mo
share/locale/en_CA/LC_MESSAGES/gnome-keyring.mo
share/locale/en_GB/LC_MESSAGES/gnome-keyring.mo
share/locale/es/LC_MESSAGES/gnome-keyring.mo
+share/locale/eu/LC_MESSAGES/gnome-keyring.mo
share/locale/fi/LC_MESSAGES/gnome-keyring.mo
share/locale/fr/LC_MESSAGES/gnome-keyring.mo
share/locale/hr/LC_MESSAGES/gnome-keyring.mo
share/locale/hu/LC_MESSAGES/gnome-keyring.mo
+share/locale/id/LC_MESSAGES/gnome-keyring.mo
share/locale/is/LC_MESSAGES/gnome-keyring.mo
share/locale/it/LC_MESSAGES/gnome-keyring.mo
share/locale/ja/LC_MESSAGES/gnome-keyring.mo
@@ -27,18 +32,21 @@ share/locale/ko/LC_MESSAGES/gnome-keyring.mo
share/locale/lt/LC_MESSAGES/gnome-keyring.mo
share/locale/mn/LC_MESSAGES/gnome-keyring.mo
share/locale/ms/LC_MESSAGES/gnome-keyring.mo
+share/locale/nb/LC_MESSAGES/gnome-keyring.mo
share/locale/nl/LC_MESSAGES/gnome-keyring.mo
share/locale/no/LC_MESSAGES/gnome-keyring.mo
share/locale/pa/LC_MESSAGES/gnome-keyring.mo
share/locale/pl/LC_MESSAGES/gnome-keyring.mo
share/locale/pt/LC_MESSAGES/gnome-keyring.mo
share/locale/pt_BR/LC_MESSAGES/gnome-keyring.mo
+share/locale/ro/LC_MESSAGES/gnome-keyring.mo
share/locale/ru/LC_MESSAGES/gnome-keyring.mo
share/locale/sk/LC_MESSAGES/gnome-keyring.mo
share/locale/sq/LC_MESSAGES/gnome-keyring.mo
share/locale/sr/LC_MESSAGES/gnome-keyring.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-keyring.mo
share/locale/sv/LC_MESSAGES/gnome-keyring.mo
+share/locale/ta/LC_MESSAGES/gnome-keyring.mo
share/locale/th/LC_MESSAGES/gnome-keyring.mo
share/locale/tr/LC_MESSAGES/gnome-keyring.mo
share/locale/uk/LC_MESSAGES/gnome-keyring.mo