aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/e2fsprogs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/e2fsprogs/Makefile')
-rw-r--r--sysutils/e2fsprogs/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 916888520fd..efffa2e134b 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -15,15 +15,13 @@ MAINTAINER?= mandree@FreeBSD.org
COMMENT?= Utilities & library to manipulate ext2/3/4 filesystems
PATCH_STRIP= -p1
+USE_GCC= 4.2+
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-fsck --disable-e2initrd-helper \
--with-root-prefix='${PREFIX}'
-#CONFIGURE_ENV+= CPPFLAGS='${CPPFLAGS} -I${WRKSRC}/lib \
-# -I${LOCALBASE}/include -D_EXT2_USE_C_VERSIONS_'
-CONFIGURE_ENV+= CPPFLAGS='${CPPFLAGS} -I${WRKSRC}/lib \
- -I${LOCALBASE}/include'
+CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
OPTIONS?= NLS "Enable national language support" on