aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/kf5-sonnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/kf5-sonnet/Makefile')
-rw-r--r--textproc/kf5-sonnet/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/textproc/kf5-sonnet/Makefile b/textproc/kf5-sonnet/Makefile
new file mode 100644
index 00000000000..badbafcc296
--- /dev/null
+++ b/textproc/kf5-sonnet/Makefile
@@ -0,0 +1,19 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= sonnet
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= textproc kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 plugin-based spell checking library
+
+LIB_DEPENDS= libaspell.so:textproc/aspell \
+ libhunspell-1.3.so:textproc/hunspell
+
+USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
+USE_KDE= ecm
+USE_QT5= buildtools_build core gui linguisttools qmake_build \
+ testlib widgets
+
+.include <bsd.port.mk>