aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-RDF-Notation3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-RDF-Notation3/Makefile')
-rw-r--r--textproc/p5-RDF-Notation3/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/p5-RDF-Notation3/Makefile b/textproc/p5-RDF-Notation3/Makefile
new file mode 100644
index 00000000000..5ec849967a6
--- /dev/null
+++ b/textproc/p5-RDF-Notation3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: RDF::Notation3
+# Date created: 21 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RDF-Notation3
+PORTVERSION= 0.40
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RDF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= RDF::Notation3.3 RDF::Notation3::PrefTriples.3 \
+ RDF::Notation3::ReaderFile.3 RDF::Notation3::ReaderString.3 \
+ RDF::Notation3::Template::TReader.3 \
+ RDF::Notation3::Template::TTriples.3 RDF::Notation3::Triples.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @find ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ '$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
+
+.include <bsd.port.mk>