aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/pdftohtml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/pdftohtml/Makefile')
-rw-r--r--textproc/pdftohtml/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/textproc/pdftohtml/Makefile b/textproc/pdftohtml/Makefile
index d2b10cd7c46..93737c700a1 100644
--- a/textproc/pdftohtml/Makefile
+++ b/textproc/pdftohtml/Makefile
@@ -15,11 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= erwin@FreeBSD.org
COMMENT= A command-line tool for converting pdf-files into html
-RUN_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/${GSPORT}
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_REINPLACE= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
.for file in goo/Makefile xpdf/Makefile
${REINPLACE_CMD} -e "s|-O2||; s|-g||" ${WRKSRC}/${file}