aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/qstardict/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/qstardict/Makefile')
-rw-r--r--textproc/qstardict/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index 1dc4d2188f2..4709138d8b7 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -9,15 +9,20 @@ MASTER_SITES= http://qstardict.ylsoftware.com/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt 4 based dictionary program (stardict clone)
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= dos2unix pkgconfig qmake tar:bzip2
-USE_QT4= gui network xml uic_build moc_build rcc_build
+USE_QT4= corelib gui network xml uic_build moc_build rcc_build
+USE_GNOME= glib20
+USE_XORG= x11
DOS2UNIX_FILES= qstardict.pri
# Path to dictionaries installed by stardict-* ports
DICPATH= ${LOCALBASE}/share/stardict/dic
OPTIONS_DEFINE= DBUS DOCS NLS
-OPTIONS_DEFAULT:= ${OPTIONS_DEFINE}
+OPTIONS_DEFAULT=DBUS
OPTIONS_SUB= yes
DBUS_USE= QT4=dbus
@@ -33,7 +38,7 @@ post-patch:
${WRKSRC}/plugins/stardict/stardict.cpp
post-patch-DOCS-off:
- ${REINPLACE_CMD} -e "/^INSTALLS/s|docs||g" \
+ @${REINPLACE_CMD} -e "/^INSTALLS/s|docs||g" \
${WRKSRC}/qstardict.pro
.include <bsd.port.mk>