aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cdiff/Makefile2
-rw-r--r--textproc/cdiff/src/cdiff.15
-rw-r--r--textproc/cdiff/src/cdiff.sh2
3 files changed, 5 insertions, 4 deletions
diff --git a/textproc/cdiff/Makefile b/textproc/cdiff/Makefile
index 9be85310cd3..48c96b99029 100644
--- a/textproc/cdiff/Makefile
+++ b/textproc/cdiff/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= cdiff
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= textproc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/textproc/cdiff/src/cdiff.1 b/textproc/cdiff/src/cdiff.1
index a399b04bf6c..eaa617a574a 100644
--- a/textproc/cdiff/src/cdiff.1
+++ b/textproc/cdiff/src/cdiff.1
@@ -37,8 +37,9 @@
.Op Ar diff ...
.Sh DESCRIPTION
.Nm
-reads a unidiff or context diff from stdin or a set of files and URLs, adds color
-codes, expands tabs to 8 spaces, and passes the results to
+reads a unidiff or context diff from stdin or a set of (optionally compressed)
+files and URLs, adds color codes, expands tabs to 8 spaces, and passes the
+results to
.Xr less 1 .
If used on a color terminal, it makes diffs much easier to read.
.Sh AUTHORS
diff --git a/textproc/cdiff/src/cdiff.sh b/textproc/cdiff/src/cdiff.sh
index 6824cb89811..73827e4587e 100644
--- a/textproc/cdiff/src/cdiff.sh
+++ b/textproc/cdiff/src/cdiff.sh
@@ -6,7 +6,7 @@
fetch -q -o - $1
;;
*)
- cat $1
+ zcat -f $1
;;
esac
shift;