aboutsummaryrefslogtreecommitdiffstats
path: root/www/httptunnel/files/patch-aa
diff options
context:
space:
mode:
Diffstat (limited to 'www/httptunnel/files/patch-aa')
-rw-r--r--www/httptunnel/files/patch-aa48
1 files changed, 48 insertions, 0 deletions
diff --git a/www/httptunnel/files/patch-aa b/www/httptunnel/files/patch-aa
new file mode 100644
index 00000000000..43c47a9a45b
--- /dev/null
+++ b/www/httptunnel/files/patch-aa
@@ -0,0 +1,48 @@
+--- common.c.orig Wed Dec 15 06:39:03 1999
++++ common.c Thu Mar 16 02:48:06 2000
+@@ -115,7 +115,7 @@
+ #endif
+
+ int
+-server_socket (int port, int backlog)
++server_socket (struct in_addr addr, int port, int backlog)
+ {
+ struct sockaddr_in address;
+ int i, s;
+@@ -131,10 +131,12 @@
+ strerror (errno));
+ }
+
++ memset(&address, '\0', sizeof address);
++ address.sin_len = sizeof address;
+ address.sin_family = PF_INET;
+ address.sin_port = htons ((short)port);
+- address.sin_addr.s_addr = INADDR_ANY;
+-
++ address.sin_addr = addr;
++
+ if (bind (s, (struct sockaddr *)&address, sizeof (address)) == -1)
+ {
+ close (s);
+@@ -153,8 +155,10 @@
+ int
+ set_address (struct sockaddr_in *address, const char *host, int port)
+ {
+- address->sin_family = PF_INET;
+- address->sin_port = htons ((short)port);
++ memset(address, '\0', sizeof *address);
++ address->sin_len = sizeof *address;
++ address->sin_family = AF_INET;
++ address->sin_port = htons((u_short)port);
+ address->sin_addr.s_addr = inet_addr (host);
+
+ if (address->sin_addr.s_addr == INADDR_NONE)
+@@ -334,7 +338,7 @@
+ p = strchr (*name, ':');
+ if (p != NULL)
+ {
+- *port = atoi (p + 1);
++ *port = atoi(p + 1);
+ *p = '\0';
+ }
+ }
06:48:12 +0800'>2018-02-102-4/+4 * devel/eric6: update to 18.02dbn2018-02-081-3/+3 * - Bump PORTREVISION. Lazarus was updated to 1.8.0acm2018-02-011-2/+2 * Securityupdate to 4.9.2:joneum2018-01-192-4/+4 * lang/eric6: update to 17.12dbn2018-01-171-3/+3 * devel/eric6: update to 17.11.1, add FLAVORSdbn2018-01-112-3/+4 * Securityupdate to 4.9.1:joneum2017-12-022-7/+6 * For ports that are marked BROKEN on armv6, and also fail to build onlinimon2017-11-301-0/+1 * russian/wordpress: Update distinfoswills2017-11-202-3/+4 * russian/wordpress: Update to 4.9swills2017-11-172-4/+4 * Update to 5.3.7.jkim2017-11-031-5/+5 * */wordpress: update to 4.8.3joneum2017-11-022-4/+4 * evel/eric6: update to 17.10dbn2017-10-271-3/+3 * Change CONFLICTS to CONFLICTS_INSTALLrodrigo2017-10-151-1/+2 * Update to 4.8.2joneum2017-10-062-4/+4 * Fix kde4-l10n packages after sysutils/filelight's updatetcberner2017-09-172-2/+1 * Update to 5.3.6.jkim2017-09-061-5/+5 * Remove expired ports:rene2017-08-236-127/+0 * - russian/wordpress: Update from 4.8 to 4.8.1joneum2017-08-042-4/+4 * Update to 5.3.5.jkim2017-08-041-5/+5 * Deprecate ports BROKEN for more than 6 monthsantoine2017-07-221-0/+2 * Update to 5.3.4.jkim2017-06-221-5/+5 * Update the Calligra ports to 3.0.1.rakuco2017-06-175-90/+0 * - Update to 4.8wen2017-06-092-4/+4 * - Switch to options helpersamdmi32017-06-031-3/+6 * Mark some ports failing on armv6, for errors classified as "clang".linimon2017-05-271-1/+2 * Update to 5.3.3.jkim2017-05-201-5/+5 * Update to 4.7.5sunpoet2017-05-192-4/+4 * Update to 5.2.7.jkim2017-05-051-5/+5 * Chase ffmpeg 3.3 update (ABI changes)riggs2017-04-252-1/+2 * - Revert the php7 switch, we can't force users to switch to php7 yet.miwi2017-04-251-1/+0 * - Update to 4.7.4miwi2017-04-252-4/+5 * Rename the magic DISTVERSION into SPELLVERSION for the aspell ports.mat2017-04-121-1/+1 * Remove obsolete PROJECTHOST.mat2017-03-311-1/+0 * Update to 5.2.6.jkim2017-03-281-5/+5 * Remove all USE_OPENSSL occurrences.mat2017-03-151-2/+1 * russian/wordpress: Update from 4.7.2 to 4.7.3tz2017-03-072-4/+4 * - Bump PORTREVISION. Lazarus was update to 1.6.4acm2017-03-021-2/+2 * - Bump PORTREVISION. Freepascal was updatedacm2017-02-271-2/+1 * Update to 5.2.5.jkim2017-02-011-5/+5 * Update to 4.7.2sunpoet2017-01-282-4/+4 * Update WWW: SF redirects to https://sourceforge.net/projects/<PROJECT_NAME>/sunpoet2017-01-213-3/+3 * Extract do-patch into a separate script.mat2017-01-171-2/+1 * Update to 4.7.1sunpoet2017-01-15