aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_dav
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_dav')
-rw-r--r--www/mod_dav/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/www/mod_dav/Makefile b/www/mod_dav/Makefile
index c2b69d002db..a6d69392057 100644
--- a/www/mod_dav/Makefile
+++ b/www/mod_dav/Makefile
@@ -14,12 +14,10 @@ DISTNAME= mod_dav-${PORTVERSION}-${APACHE_VERSION}
MAINTAINER= patrick@mindstep.com
COMMENT= An Apache module that provides DAV capabilities
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-
# This port will work with the following version of Apache and anything newer.
APACHE_VERSION= 1.3.6
+USE_APACHE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--bindir=${PREFIX}/bin \
@@ -29,7 +27,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--sysconfdir=${PREFIX}/etc/apache \
--datadir=${PREFIX}/share/apache \
--includedir=${PREFIX}/include/apache \
- --with-apxs=${PREFIX}/sbin/apxs
+ --with-apxs=${APXS}
CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
PATH="${PREFIX}/bin:${PREFIX}/sbin:${PATH}"