aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php5/scripts/configure.php
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_php5/scripts/configure.php')
-rw-r--r--www/mod_php5/scripts/configure.php6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 7b71120d541..ed74b8d959d 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -141,8 +141,10 @@ while [ "$1" ]; do
fi
;;
\"SybaseDB\")
- echo "LIB_DEPENDS+= sybdb.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= sybdb.1:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASECT" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
@@ -152,7 +154,9 @@ while [ "$1" ]; do
;;
\"SybaseCT\")
echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase-ct=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASEDB" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc