aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_security/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_security/Makefile')
-rw-r--r--www/mod_security/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
new file mode 100644
index 00000000000..a46df01cff8
--- /dev/null
+++ b/www/mod_security/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: mod_security
+# Date created: 4 June 2003
+# Whom: Alex Dupre <sysadmin@alexdupre.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_security
+PORTVERSION= 1.5
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mod-security
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= sysadmin@alexdupre.com
+COMMENT= An intrusion detection and prevention engine
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/apache2/apr.h)
+WITH_APACHE2= yes
+.endif
+
+APXS?= ${LOCALBASE}/sbin/apxs
+.if defined(WITH_APACHE2)
+APACHE_PORT?= ${PORTSDIR}/www/apache2
+APWRKSRC?= ${WRKSRC}/apache2
+PLIST_SUB= APACHE=apache2
+.else
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+APWRKSRC?= ${WRKSRC}/apache1
+PLIST_SUB= APACHE=apache
+.endif
+
+BUILD_DEPENDS+= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS+= ${APXS}:${APACHE_PORT}
+
+DOCS= CHANGES INSTALL LICENSE README modsecurity-manual-v1.5.pdf
+
+do-build:
+ @cd ${APWRKSRC} && ${APXS} -c mod_security.c
+
+do-install:
+ ${APXS} -i -a -n security ${APWRKSRC}/mod_security.so
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/httpd.conf.example-* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>